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The biggest issue preventing Linux from taking
over the desktop is not a lack of availability of
applications programs, hardware requirements
or anything technical. The biggest obstacle 
is fear.

The funny thing is that it tends to be the
more knowledgeable people who have this
fear. That is, those who consider themselves
Windows Power Users are more likely to be
afraid of Linux than a relative newcomer 
to computing.

Let me offer an example. When I was first
living in Costa Rica, my neighbor asked me if
his maid, Rosa, could use my computer to
check her e-mail. Rosa speaks no English, and
her computer experience has been limited to
using systems in Internet cafés. Her e-mail
account is on Yahoo and, thus, is Web-based. I
told him, sure, and he and Rosa came over to

try things out.
Rosa looked at me and asked if “it” was in

Spanish. I told her it was. (Different KDE logins
can be in different languages, and I had a
guest login set up in Spanish.) That was the
last question she asked. She sat down and
used Konqueror, the KDE browser, to do what
she had done in an Internet café.

This example is not atypical. In fact, ten-
year-old kids who have never used a computer
before are very happy to sit down, run Tux
Paint or Potato Guy and use the system.
Telling them that this is a Linux system just
gets me the same blank stare as if I had said
SCSI disks tend to be more reliable than 
IDE disks.

Now, what about that power user?
Although I hear all sorts of concerns from
Windows Power Users, virtually all of them
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boil down to “it’s different”. Well,
that’s true—unless you come from a
UNIX background. That likely explains
why Linux is taking over the Web serv-
er business, where UNIX was the de
facto standard.

Most of these differences to the
Windows Power User are “on the
inside”. That is, the changes in the
user interface are not large issues.
Anyone who has been using desktop
computers for a few years knows
changes happen as part of the natural
evolution of the desktop.

Rather than try to explain those
inside differences, let me justify them.
Many of those differences are the rea-
sons behind the following:

� Linux is much less likely to be 
damaged by viruses and worms.

� Linux offers the user a choice of
desktop environments.

� Linux offers user-level protection
from mistakes of other users.

� Linux supports interoperability with

many other types of systems.

I have been told that Linux is hard
to install. It turns out that the majority
of the people who told me that had
never installed any operating system
on a computer. That is, the computer
came from the store with some version
of Windows installed. If there was a
problem, they brought the computer
back to the store. Or, they got their
brother-in-law or son to re-install 
the software.

The good news is that stores will sell
you a computer with Linux pre-installed.
Better still, you can choose which
“brand” of Linux you want installed.
Different Linux distributions offer differ-
ent levels and types of support.

Sure, some are free and some cost
money. Once again, that’s choice. If
you (or your brother-in-law) are capa-
ble of doing your own support, great.
The free versions might be perfect 
for you. If not, you have a lot of 
other choices.

Adoption of Linux on the desktop
seems to be happening faster outside
the US than inside. I see multiple con-
siderations driving this trend.

The first is economics. Today, it
costs more to buy a commercial oper-
ating system, office suite and all the
other programs you need than it costs
to buy the computer itself. People and
companies just can’t afford these
prices. If you don’t consider Linux as a
solution, you are left with few alterna-
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tives. You can steal the software or do
without. Or, you can find an alterna-
tive you can afford, such as Linux.
When I lived in Costa Rica, I saw indi-
viduals, companies and government
pick Linux as the best way to address
economics.

Although economics certainly play
into government decisions in Brazil 
and Germany, there are other reasons
why Linux is attractive. Reliability,
mostly in the form of immunity to
viruses and worms, is one big advan-
tage Linux has over the competition.
So is maintaining control. That is, with
Linux, the consumer has much more
control over what to upgrade and
when to upgrade. For example, com-
mercial software companies often
require you to purchase and install 
a new version of their software to
address problems with the current 
version. This is a costly, risky and 
complicated solution. If the company
uses Linux, it could elect to install a
patch to their systems to address the
problem instead.

Finally, I see a different attitude that
helps promote Linux more than com-
mercial alternatives in other countries.

In the US, advertising is a significant
factor driving purchasing decisions. If
you don’t believe that, look at the
fast-food industry. The biggies in this
field don’t necessarily make better
hamburgers—it is just that brand
recognition herds people to their 
products.

Where I live, word of mouth is the
most important factor in getting mar-
ket share. For example, more than
50% of the vehicles in this area are
Toyotas. This isn’t because Toyota 
has a big advertising campaign; it 
is because people talk about their 
vehicles, and Toyota has come out 
way above the alternatives.

This doesn’t necessarily mean that 
a Toyota pickup is better than a
Mitsubishi. It simply means that the
local perception is that a Toyota is 
better than a Mitsubishi, and that 
perception comes from the personal
experience people have with Toyotas.
Even a big advertising campaign by
Mitsubishi would be unlikely to 
change the minds of more than a 
few people here.

Linux word of mouth tends to be
very positive. It just doesn’t take a lot

of people saying “Linux solved my
problems and it cost less than the
alternatives” before you see people
giving it a serious look.

For those who are still afraid, you
can take the Linux plunge without
even loading it on your computer.
Multiple Linux distributions will run
directly from your CD drive. They 
will be much slower than if Linux 
were loaded onto your hard disk, 
but it may be a good way to address
your fear.

The most popular choice is Knoppix.
You can find out about it on the Web
at http://www.knopper.net/knoppix/
index-en.html. Knoppix is a noncom-
mercial choice you can try without
installing anything. Commercial Linux
vendors also offer live evaluations for
free. Novell offers a live evaluation CD
for its SUSE distribution. Go to
http://www.novell.com/linux/suse/
index.html and search for “live eval”.

So, in conclusion, I think anyone
can use Linux. But, you don’t have to
take my word for it. There are free and
easy ways to try it out for yourself.�

Phil Hughes is Group Publisher for SSC Publishing, Ltd.

P2P

4www.tuxmagazine.com

http://www.knopper.net/knoppix/
http://www.novell.com/linux/suse/
http://www.knopper.net/knoppix/index-en.html
http://www.novell.com/linux/suse/index.html
http://www.tuxmagazine.com


The jury will please turn its attention to the evidence marked
Exhibit 1. I just finished a monster of a report for Evans Data
Corporation. This report was an analysis of data collected from
every imaginable type of Linux developer. Now I know that
many, if not most of you reading this right now, aren’t likely to
be programmers, let alone Linux application developers. But,
the survey data was packed with information that even the
most unexperienced amateur of Linux should know. Evans
wants to sell this report, so I can’t give away all the juicy
details. However, I can tell you enough general information
that should surprise and delight you.

If there is one bit of data in the report more than any
other that should raise eyebrows, it is the fact that the
respondents named Linux as the best operating system for
personal desktop productivity. In case you’re not up with
the journalist lingo, that means they said it’s better than
Windows as an easy-to-use desktop for getting your work
done. Granted, Windows ranked a very close second, and
the difference fell within the margin of error. But the last
time we asked a question even remotely similar to this one
(about a year ago), Linux hardly showed up as a blip on the
radar. For years, these respondents chose Linux as the best
operating system for everything but personal productivity.
Until this survey, respondents believed that when it comes
to Web browsing, writing documents, working with spread-

sheets, exchanging e-mail, managing your calendar and all
the rest of the things people do, it was all Windows,
Windows, Windows. Linux not need apply.

Admittedly, the people who responded to this survey are
technical people, not home users or nontechnical office
workers. But aside from the fact that there has been a sud-
den change in their perception of Linux as a platform for
personal productivity, there’s data in the survey that shows
they believe home users and office workers will be adopt-
ing Linux on the desktop too.

There are many other results in the survey that support
this conclusion, but I’ll leak only a little more information;
otherwise, Evans Data is likely to put bamboo shoots under
my fingernails, drill my teeth with no anesthetic or worse,
make me attend a Britney Spears concert.

For the first time, developers are writing more applications for
Linux than they are for Windows. More important, a significant
percentage of the applications they are writing represent
graphical applications for the desktop. Past surveys indicated
that they used Linux almost exclusively for writing server
applications, with very little interest in addressing the desktop
market. The inference should be obvious. If developers are
working on desktop applications, they must believe now more
than ever that they can sell them.

Okay, enough of Exhibit 1. If the jury will now please
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turn its attention to the evidence
marked Exhibit 2, which happens to
include a shameless plug for a book I
co-wrote with a fellow named Jono
Bacon. The book is called Linux
Desktop Hacks, and if it isn’t on the
shelves now, it will be soon. This book
is published by O’Reilly, which, if you
know the publishing industry, would
tell you that O’Reilly expects people to
buy it. No book idea is a sure thing,
but O’Reilly has a good record for iden-

tifying a market and publishing books
that sell into that market.

You also should know that the Linux
Server Hacks book is one of their best-
selling books. But now O’Reilly believes
there is enough of a Linux desktop
market that a book on Linux desktop
hacks should be successful. (And, it will
be if you all run out and buy it the
moment it hits the shelves—hint, hint.)

Seriously, Linux Desktop Hacks is

written primarily for Linux users with
varying levels of technical expertise,
from competent amateur to expert
hacker (although some of the hacks
probably are easy enough for grandma
too). So even though I encourage you
to look at it, I won’t be offended if
many TUX readers find it too technical
to be useful. (Of course, you could buy
it for some technical person you
know—okay, okay, enough of that, 
I promise.)

Now if the jury will please turn its
attention the evidence marked Exhibit
3. Just ask yourself the question, what
does Linux lack at this point? KDE, the
most popular graphical desktop, has
features Windows could only hope to
have—and I mean hope, because some
of the features Microsoft would never
dare implement. For example, you can
pop an audio CD into your CD-ROM
drive, open up a Konqueror window

and create MP3 files of all the songs on
that CD with a simple drag-and-drop
operation. Microsoft, on the other
hand, is a toadie for the music industry
and is therefore working hard to pre-
vent you from doing things like that,
lest you create an MP3 file in order to
break a copyright.

We have OpenOffice.org, an office
suite with all the features people actually
use. If you don’t like OpenOffice.org,
there are other free and commercial office
suites from which to choose. I daresay
that we Linux users have more office soft-
ware to choose from than Windows users,
because Microsoft virtually has eliminated
all the competition. And, when I absolutely
must use a program like Microsoft Word
(some publishers insist upon it), I run it on
Linux with either CrossOver Office
(http://www.codeweavers.com) or Win4Lin
(http://www.netraverse.com).

In summary, dear jury, I suggest you
prepare for the Linux desktop revolu-
tion. It’s happening now. Trust me—
you want to be a part of it.�

TUX Editor in Chief Nicholas Petreley is an author,
consultant, programmer, award-winning columnist
and Linux analyst for Evans Data Corp.
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MS Bashing?
First off, I wanted to thank the whole TUX team
for putting together this magazine. I think this
publication is going to be a great tool/resource for
me and the rest of your subscribers. There wasn’t
an article that I couldn’t take something away
from. Keep up the good work!

My only complaint was the blatant and needless
MS bashing in the opening editorial. Linux stands
up well enough on its own without the need to
stoop down to Microsoft’s level with all the FUD
slinging. I would think that people in this industry
understand that there are choices and that not
every option is best suited to every scenario. I
have many PCs at home, all but one run Linux,
and I wouldn’t have it any other way.
--
Andrew

We at TUX consciously avoid bashing Microsoft in
our articles. Our job is to promote Linux, however,
and even more importantly it’s our passion to pro-
mote Linux. Sometimes, it is important in an article
to point out the ways in which Linux is superior to
its most visible competition, Windows. This can
sometimes be misinterpreted as Windows bashing,
but it is simply addressing an important fact the
reader should know. Although, I can tell you it’s
our goal to stay away from “bashing” in general.

Obviously, opinion columns are not subject to the
same rules, because everything in the column is
the author’s opinion, with which readers are free
to agree or disagree.

Thanks again for your input, and we hope you
continue to enjoy the magazine!—Ed.

Help with International Characters
First things first, a big thank you for such a timely
magazine. The stuffs are great, and I am still try-
ing to finish reading your site and the down-
loaded PDF (another great) file.

I was a little disappointed in the Web article
“Entering International Characters”, though. 
I am hoping to understand how to input cjk
characters in a mostly English document, for
example, Mr so and so, who happens to be
Japanese/Korean/Chinese, with the rest of the
document in English.

I am using SUSE 9.2 (5 CD) and had to surf the
Net for weeks but to no avail. In fact, I had found
that many people are asking the same question,
but it seems like nobody takes notice. Any chance
of a small article to explain this little trick? Again,
a million thanks for the great stuffs!!
--
Michael

ShortKeys for Linux?
First off, thank you for TUX magazine. I have
my electronic subscription and love it. Thank
you very much.

As a Windows refugee, most of the MS pro-
grams I used are a distant memory; however,
there is one I miss and would really like to see
either ported to Linux or mimicked. That pro-
gram is ShortKeys. It is simple. I set up the key
shortcuts and it types the word for me. As an
example, if I want to type my company name,
MobileMaster of Austin, with ShortKeys, all I
have to type is mmm, and it happens. I have
looked at khotkeys but not only is it very com-
plex, there seems to be some real problems
with the software. I have been in contact with
the author of ShortKeys, and he has told me
he has no interest in Linux. Is there anything
comparable in Linux? Can you help?
--
Ken Starks

We will forward this question to Mango Parfait,
the author of our new Q&A column, Q&A with
Mango Parfait. It was too late to get it to her
for this issue, but perhaps she’ll elect to address
it in a future issue.—Ed.
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Thanks TUX
I just wanted to say that you guys at TUX maga-
zine are doing a great job. It’s nice finally to see a
magazine tailored to the new Linux user. I also like
the fact that it keeps the Linux spirit and is free to
anyone that wants it. It has a nice format; it’s very
professional looking, and I also think it’s a great
idea for the issues to be on-line. Keep up the
great work guys, I hope to read more!

On a side note, I think it would cool to see some-
thing on the different methods of installing pro-
grams. I mean, there’s dependencies, .rpm files
and .deb files just to start off with. And maybe
something on the future of installing programs on
Linux.
--
Schuyler

Congratulations, But...
I would like to congratulate you on your first edi-
tion, it was a change to see basic straightforward
articles rather than those that start of showing
you the latest development program assuming
that all Linux users are developers.

But (you knew there was a but coming), I found it
very heavy going reading it on-screen. I don’t
know if articles I have read on-line in the past
have been “lightened” text-wise to make it easier
to read, but yours is more of a magazine that has
been put on-line. Sorry if that sounds like stating
the obvious.

I will eagerly await the next issue with anticipation
--
Tim Henley

KDE vs. GNOME
Thanks for the new on-line edition of TUX. I think
that it’s a great concept. As I was browsing
through the magazine, I noticed that the articles
covered were for software designed for the KDE
environment. While I think that this is a good
idea, it would be great if there was more balance
in covering the software for those users that use
Linux desktop environments other than KDE (such
as GNOME). While it is true that much KDE-ori-
ented software will work with GNOME, it is still a
good idea to have articles for those of use who
are using the GNOME desktop environment.
--
Jeffrey

Our authors are instructed to include GNOME-
related information whenever it is useful, and we
will certainly print some GNOME-centric articles.
The fact is, however, that KDE has the largest
market share, and that means the majority of our
readers probably use KDE most, or use only KDE.
That is the reason for our emphasis on KDE.—Ed.

For the Average Joe
I personally would like to thank you for providing
a magazine for the average joe. I used to love
Maximum Linux and was distraught when it
ended. I have been looking forward to a new gen-
eral-user Linux mag since.

I have been using Linux on and off for a few
years now (since Mandrake 7.0). Generally, I try
each new release for a while, decide it’s not quite
up to snuff yet, then go back to Windows.
Finally, with Mandrake 10.0, I seem to be able to
settle in with Linux. Linux seems VERY close to
being a complete Desktop OS.

As a small home-business owner (just starting up), I
am very interested in keeping Linux for my business
needs (for cost and security reasons). For the most
part, I am happy. I run OpenOffice.org, Mozilla and
Nvu (kind of slow) for my general office and Web
design stuff, and I use Cadsoft’s Eagle Schematic and
PCB layout package for my design work. As you can
see, I am very careful to pick software applications
that are available for both Windows and Linux. I pur-
chased a copy of Netraverse’s Win4Lin 5 and
installed an old copy of Windows 98—VERY nice!!!!
It works very well for the various software items that
I can’t find for Linux—mainly QuickBooks, Avery
Label Software and TurboCad.

Sorry for the above monologue. The main reason
for this e-mail is to request a topic. An article on
using Linux for a small business would be great. I
have had quite a bit of trouble finding information
on accounting packages and how they compare to
the Windows equivalents. My personal main inter-
ests are accounting software, voice-mail/Fax soft-
ware, Web design software and label software.
--
Craig Lindholm
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Requests
Let me start by thanking you. This magazine is fill-
ing a very important void. As the “driver, not
mechanic”-type Linux user you’re targeting, I have
found a dramatic lack of information I can use. I’m
lucky not to have been told too many times to
“RTFM”, but most the manuals and articles I’ve
read require a background knowledge that I’m hav-
ing to fight to build for myself. I’m really looking
forward to a “normal-user”-oriented magazine.

I wanted to suggest an article idea. The variety of
Linux distros available can be pretty overwhelm-
ing. Everyone I talk to has a preference, though
not many can tell me why they prefer this over
that. How about an article describing what the
differences are at the user-level. There is plenty of
information on Knoppix and Ubuntu being
“Debian-based”, while Mandrake evolved from
Red Hat for instance, but I have no idea what
that means. I’m interested in a few paragraphs
on each of six to ten different distributions telling
me what differences I’ll see in them that would
make me prefer one over the other.

Another article I’d love to see is a how-to list (cheat
sheet?) including how to install a .tar application,
how to find and use CD burning software, and
other everyday activities that most computer people
take for granted. In making the transition from
Windows to Linux, all of that changes somewhat. A
concise list of the most commonly performed tasks
and how to do them in a Linux environment would

be really helpful. I hope these are useful to you, and
thanks again for setting up the magazine.
--
Donovan Hoggan

Thanks for your input. We are discussing how to
create cheat sheets like the ones you suggested,
and whether or not to publish them separately or in
TUX. We will also do what we can to schedule an
article that sorts out the differences between distri-
butions and puts the information in layman’s terms.
See next issue for an article on CD burning—Ed.

More GNOME
Just wanted to write a quick note to say that I
really enjoyed the first issue. I am only about three
months new to Linux and have been enjoying my
new Microsoft-Free environment throughly.

In future issues I would love to see more articles
on GNOME-based applications rather than strictly
“K”-based ones. Or, just have authors clearly
specify that the “application is installable and
usable under the following desktops: GNOME,
KDE and so on.” Additional topics I’d love to see
covered would be how to sync the PocketPC with
Linux; running a Linux distro on the PocketPC (yes,
I know, kind of advanced for newbies); and more
reviews and info of Linux-based devices like
Pepper (for example, the Sharp Zaurus). Best of
luck with the new publication!!
--
Jeffrey

The New Cell Processor
I’d like to see an article on the new cell processor pro-
duced by Sony, Toshiba and IBM. The article would
start out something like this: “The new cell processor
processes graphics ten times faster than the best
Pentium. IBM says it will incorporate the chip in a
new workstation later this year. Wonder which oper-
ating system. Could it be Linux? Is this the start of a
new empire? Lincell instead of Wintel?”
--
Ralph Paidock

Bravo
Bravo on your first issue! It was way more than I
had hoped for! I now feel confident that I can
switch my home PC over to Linux in the near
future, except for two questions:

1) How do I set up DSL on Linux? Could you put
together a tutorial on that, along with some trou-
bleshooting tips? I can’t be isolated from the
Internet for very long before I get the DTs!

2) How do I set up printing? I have a Brother MFC
6800 that I will probably have a hard time finding
Linux drivers for.

Maybe you can start a new column answering ques-
tions like these from subscribers and call it something
like, “Ask Dr Tux” (or something wittier).

Thanks for the help. I showed a printout of your
mag to the guys during our local Linux Users’
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Group meeting (http://mgalug.org), and they were
impressed, too. I can’t wait for the next issues,
especially the one about personal finance s/w!
Thanks once again—you guys are yet another
example of the excellence I see all over the place
in the Linux community!
--
Bill Chaney

Screensaver to Share
I have created a screensaver for Windows systems
that will display a tutorial for Linux commands, and
wish to share it with the world. I am going to use this
tool at our school to beef up CLI knowledge, and am
also sharing it with the world. This is the first version,
and there will be more releases that will teach differ-
ent objectives aligned with system administration. The
address is http://waskillsusa.tstc.edu. The program is
located in the news section (right above a link to your
Web site).
--
WY

More Thanks
I just finished reading (cover to cover) your first
issue of TUX magazine. All I can say is Wow. I
want to thank you for creating such a useful, pro-
fessional and FREE e-zine. I appreciated the clear,
jargon-free directions (which is often lacking in
man pages). I especially enjoyed your look at The
GIMP. I have spent years becoming (somewhat)
proficient in Photoshop, so I have been reluctant
to begin a new learning curve. Your article has

convinced me to take another look at The GIMP,
and I will be looking forward to future articles and
collecting them for future reference.

Although I have a few years of experience with
Linux, I found useful tips throughout the maga-
zine, even for programs I have been using for
quite a while.

You asked for suggestions for future articles,
and I would like to request a simple look into
securing a Linux box, from firewalls and network
scanning tools to keeping up with security
patches and updates.

I also am running an Apache Web server, so info
on configuring and securing Apache would be
helpful for me. I realize that this may be a little
more advanced than your average newbie will
use, but perhaps a section of your mag for slightly
more advanced users? Again, I would like to
thank you all for your excellent publication. It is
much more than I had hoped for. Keep up the
great work.
--
Michelle Blowers

KAudioCreator Article
I have just signed up, downloaded and printed
out the TUX magazine—I can only say thank you.
This is just what I have been looking for, I have no
problem downloading and installing Linux distri-
butions, but I have very little experience when it

comes to using the system. Your magazine pro-
vides me with some clear guidance.

The first issue contains something that I need. I
am trying to turn an old laptop into a music box
for my camper van. Your piece about ripping with
KAudioCreator has given me a big head start with
my project [see “Rip Your Audio Files Down to
Size with KAudioCreator” by James Gray, TUX,
March 2005].
--
Paul Stephenson

James Gray replies: that’s terrific, thanks for
letting me know. I had a great time putting the
article together, and I’m so pleased it helped
you, too. Good luck!

TuxScout
I’d like to let you know about a new job-search
site I recently developed that’s dedicated to 
the Linux and Open Source community:
http://tuxscout.com.

The goal of TuxScout is to provide a comprehen-
sive resource to job seekers and employers seek-
ing to scratch their respective open-source itch-
es. The site includes almost everything you’d
expect of a modern system, such as a powerful
and sophisticated search engine, discussion
forums, news feeds, links to career resources
and an updated calendar of Linux/open-source
events. TuxScout is completely free to job seek-
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ers and employers, which makes it a great
resource for many small businesses looking to
hire top Linux talent.

I’d greatly appreciate it if you could support this
effort by spreading the word in any way you can.
The site is only a few days old and is just starting
to gain some traction. With your help, TuxScout
has the potential of being an employment hub for
the entire Linux/Open Source community.
--
Sharif Alexandre

Ah, the Irony
I find it quite ironic that you have used an
advanced version of PDF for your Linux magazine
that cannot be displayed by the versions of
acroread that are available for Linux systems! 
I will have to try viewing the document with a
Windows version of Acrobat Reader. I find this to
be in extremely poor taste.
--
Collins Richey

If you try to read TUX with a browser and an
Acrobat plugin, it will not display the magazine.
We’re not sure why the plugin fails. If you down-
load the magazine as a PDF file and view it with
the Acrobat 5, you will get a warning that some
features may not be available. We do not use any
features that aren’t available, so it displays the
magazine perfectly after you close the warning
dialog box.

By the way, at the time of this writing, you can
find version 7 of Acrobat Reader for Linux at the
following FTP address: ftp://ftp.adobe.com/pub/
adobe/reader/unix/7x/7.0/enu.—Ed.

Not PDF
I originally began to sign up for a subscription
when there was going to be a hard copy of TUX. I
was disappointed that you decided not to go that
route. But I thought I would give it a try with mis-
givings. I don’t have cable/broadband. In my area,
getting 46k out of the connection is good. Trying
to download anything that takes more than ten
minutes is impossible due to flaky lines and
bounces breaking the connection. So I just tried to
look at the March issue. I can’t get to it. There has
to be a better or more diverse solution than PDF—
if you don’t want a hard copy, why not XML or
HTML so at least those of us who would like to
support/look/read it could do so?
--
Jay

Bad Documentation?
I just ran across your magazine today, and sub-
scribed immediately. This is an excellent idea. I
have concluded that a lot of programming
genius is wasted because of bad or non-exis-
tent documentation. I have tried a number of
times to do, or find out how to do, things with
GNU/Linux. Many times I have not been able to
find out, I have found something and tried to
run it and have had it not run at all, or I have

run it and gotten a screen full of buttons that
mean nothing.

I like the idea of organizing things by tasks,
such as, I want to burn a CD, or I want to sync
my Palm Pilot—how do I do it? For me, person-
ally, if I can get a foot in the door by finding
out how to do some basic function, I can help
myself to more. On the other hand, if I have to
start from nothing, with no documentation and
not even any idea of IF I can do something, or
with a program that requires some obscure
configuration, I just get nowhere.
--
Steven White

PDF Problems
I just heard about, subscribed to and downloaded
the March issue today.

My first impressions of TUX magazine are awful.

1) You FORCE OPEN the magazine in full screen
and then lock down the PDF so I can’t make the
change to prevent this in the future.

2) The dimensions are terrible. Stick with US Letter
or A4, but stick to standards—so I can more easily
print the darn thing.

3) Even if you stick with the “screen-friendly”
dimensions, the magazine is in LANDSCAPE
mode (UGH!) Reading documents in landscape
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can only politely be described as awkward.

And, I haven’t even gotten to the content yet.
If this is going to be your primary means of dis-
tribution, you need to make the magazine
friendlier to the people reading it and not
assume that everyone will want to read your
magazine only on-screen. Forcing someone to
do something YOUR way is not in the spirit of
Linux or Open Source and is certainly not going
to keep me reading.

Although the concept is sound, the execution is
terrible. I’ll be looking forward to improvements
in future issues before I decide to cancel my
subscription.

Thanks for your time, efforts and consideration,
--
Michael Potter

Once the magazine expands to full screen, you
can press Escape to get back to a window view.
We are aware of some of the problems of pub-
lishing in PDF format, and we’re working hard at
solving them.—Ed.

For Drivers
Thanks for the Magazine for “drivers” of Linux.
I am an emerging newbie in Linux and just 
love it. One thing I found was a frustration in 
terminology for the new user. Words like terminal
and shell simply don’t make sense to a common

Windows user. I believe that it’s this “technical”
jargon (and not its use as it is actually easy to
use) that makes the common computer user
“afraid” of Linux. What we need is less Linux
“mechanics” explaining the “how-tos” and more
common users, former Windows users at that,
telling the skinny on what is what in Linux. Once
we build the terminology bridge to the Windows
user, then we will see the converts start rolling
across it. Linux gets better by the day, and I am
very happy with it. It works; it’s stable; despite my
best efforts you can’t break it! As they say
though, perception is 9/10th of reality. Your
magazine will go a long way to helping tear
down those false perceptions.

Would love to see some more info on apps—
Wine is a biggie!

PS: Great look and feel to the magazine. The PDF
was awesome in my new Adobe 7.0!
--
Andrew Brown

Need Help
I enjoyed your first issue, especially the article on
managing your desktop, assigning icons and so on
[see “Customizing Your KDE Work Environment”
by Æleen Frisch, TUX, March 2005]. That was
immediately useful, as I had Firefox as a nasty-
looking script icon and my kids refused to use it!
They’re starting to use Linux (SUSE 9.1) now as
I’ve made the icons and desktop background the

same as what they had on XP.

Anyhow, we really like our free games and games
trials, and we’re always downloading and trying
stuff out on XP. So I thought, I bet there’s loads of
great stuff to play on Linux. But...what the heck is
Open GL? What’s configure, make, makefile, X11?
Do I need to install compilers? It’s not exactly an
unzip and run install program is it?

As with all things, I’m sure there’s a straightfor-
ward way to download games and play them
without needing a certificate in UNIX scripting.
Can you help/advise?
--
Kieran Caulfield

Great Design
Just grabbed your first issue after seeing the ad in
Linux Journal. Though I haven’t had time to
browse through all of your content, I’d like to
quickly mention two things. 1) The design is gor-
geous. It’s nice, simple, friendly and clean. 2)
You’ve done a nice job targeting your content. It’s
accessible to new desktop Linux users, but useful
and informative to a more experienced user like
myself. I look forward to future issues. I’m a bit
bummed out by your decision not to offer a print
edition at this time, but I’d like to say I would
almost certainly subscribe were you to offer one
again in the future.
--
Mike Baehr�
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Q&A with Mango Parfait
Mango Parfait introduces herself, answers her own questions with astounding facility and invites

you to ask her your own questions. Don’t be shy. There are no stupid questions, only stupid answers.

BY MANGO PARFAIT

13www.tuxmagazine.com

Hi. My name is Mango Parfait, or Mango-
Pafe in my native language. The publisher
of TUX wisely hired me to answer any
questions you have about Linux. Ask any-
thing about using Linux, installing Linux,
how to fix things when they don’t work
in Linux and anything else. In fact, feel
free to ask me anything at all—except my
age. That’s not polite.

I will try to answer as many questions
as possible, but I humbly apologize in
advance that I cannot answer questions
by e-mail and that some questions may
not make it into this column. I’m a busy
girl, and there is only so much room in
this magazine.

Here are my qualifications. I started
using Linux before Linus Torvalds even
thought of it, so I know more than most
of the dweeb boys I meet who gush all
over me when they find out I use Linux.

Eewww, guys, buy some Benzyl Peroxide
and learn how to talk to a girl without
using the word siskittle (how they pro-
nounce the term sysctl) in every other
sentence to try to impress me.

Speaking of being a girl, let me warn
you. If you don’t think I can answer
your questions because I’m a girl, you
better not say that to my face. I’m a
master of Jew Jitsu (a style of martial
arts I picked up during my many visits to
Israel, New York and Florida), and I
won’t hesitate to teach you a lesson in
black and blue. And, I don’t mean that
I’ll draw your picture with the graphics
program called GIMP. Truly, GIMP will
take on a whole new meaning when I’m
through with you.

If you do ask something I don’t know,
which is really not likely, it’s only because
I forgot. In that case, I have lots of

friends to call who can help me. One of
them is ex-boyfriend, Otaku, who builds
and pilots huge fighting robots. I think
he calls them Powerful and Humungous
Aggressive Robot Thingies or something
like that. Anyway, these PHARTs are pow-
ered by super-computing Linux clusters.
He not only wrote the programs to con-
trol the huge fighting robot, he pro-
grammed an artificial intelligence system
that helps him pilot, helps him fix the
robot after battles, gives him fashion
advice and can answer questions about
Linux that even he doesn’t know.

This being the first Q&A with Mango
Parfait, I have no reader questions to
answer yet. But, I still can answer ques-
tions in this issue. Some of them are
questions I hear all the time, and some I
will just make up.
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Q I am a Windows user and I don’t
know anything about Linux. What

is the easiest way for me to try it?—
Saku Shamishou

A There are some versions of Linux
that you don’t have to install in

order to use them. They run right from
the CD. Linux runs slower than usual if
you run it from CD, but it is the easiest
way to find out if Linux is for you. You
can install most of these run-from-CD
versions of Linux on your computer if
you decide you like it. Then it will run
much faster and you will have a lot
more you can do.

My favorite run-from-CD versions of
Linux are MEPIS and Knoppix. You can
find out more about MEPIS by visiting
http://www.mepis.com. You can order
a MEPIS CD from http://store.mepis.com/
home.php for only $9.95 US. You can
get MEPIS for free if you download a
CD image file and burn your own
MEPIS CD. If you are a beginner user,
you may not know how to do that, so
just send in your $9.95. It is easier and
you get a much prettier CD than one
you make yourself.

You can find out more about
Knoppix at http://www.knoppix.org.

The Web page comes up in German.
Saku Shamishou doesn’t sound like a
German name (I know, because I made
it up). So when you get to the Knoppix
home page, click on the flag that rep-
resents a language you understand, like
English. I like to pick flags with lan-
guages I don’t understand. I like Polish,
because it has all kinds of funny look-
ing letters and words without any vow-
els except maybe y, which can save you
a lot of money if you play Wheel of
Fortune on Polish TV. Russian looks
even better, and all those backward let-
ters in Russian makes me wonder if the
language was created by a four-year-
old. The Japanese site should be the
best, but it isn’t written in Japanese. It
does have two fun Java applets,
though.

Scroll down to the bottom of the
Knoppix home page. You will find a
link where you can download Knoppix
and make your own CD, and a link that
takes you to a page with lots of stores
where you can order a Knoppix CD and
do a lot of other fun shopping while
you’re there. Knoppix is cheap. One
store sells it for $3.95 US.

Naturally, you need to know how to
start up your computer with the CD

instead of the hard drive. That’s a good
question, and some real person out
there should ask it.

By the way, if any of this sounds
interesting, make sure you read the col-
umn by the publisher Phil Hughes,
“Can Anyone Use Linux?” (page 2).

Q Which Linux distribution do you
use?—Pittsa Feisu

A I use many distributions. My favorite
is Gentoo. Gentoo is not for begin-

ners or for people who want their desk-
top to be fast and responsive. It is for
people who like to watch their computer
compile software for hours and hours and
hours, which is what slows down the
desktop. (The desktop is fast if you don’t
compile programs when you use it.) I
download the latest unstable Gentoo
updates every day and watch my comput-
er compile programs all night when I have
insomnia. You risk making Gentoo unsta-
ble when you update all the time. The
most thorough way to cure the problem
is to recompile the entire system from
scratch. It takes days for Gentoo to com-
pile everything. I like to watch all the
compiler messages scroll off the screen
day after day. It is hypnotizing.

P2P
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Q Which desktop do you recommend,
KDE or GNOME?—Nakaguri

Shitsugi

A Definitely KDE. It is much prettier
than GNOME. You can change

anything about the way KDE looks,
including the colors for every detail. I
created a color theme for every outfit I
own so that I am always color-coordi-
nated with my desktop. GNOME does-
n’t let me do that, so I don’t use
GNOME unless I must.

Q When I open folders within folders
in GNOME, it leaves the parent

folders open and my screen gets clut-
tered with lots of open folders. How can
I prevent that?—Hakuchi Purogurama

A There are at least three ways to
deal with this problem. You can

edit the GNOME registry to change the
way folders work. You can right-click
on a folder and choose Browse Folder
from the menu, which opens a folder
window that is easier to navigate.

The third would be my favorite
method. If you hold down the Shift key

when you open a new folder, GNOME
closes the old folder when it opens the
new one. I said it would be my favorite
method, not that it is my favorite
method. I am happy to be delicate and
feminine and want to remain so. I do
not like to strain my finger by double-
clicking everything. So I configure
GNOME to let me open folders with a
single mouse click like KDE. The Shift
key trick doesn’t work when GNOME
opens folders with a single mouse click.

Q I changed the clock on my KDE
panel to a 12-hour format with

AM/PM, but it doesn’t work. It is still a
24-hour clock.—Carlotta Tendant

A It works. You won’t see the
change until the KDE panel

restarts. The next time you log in, you
should see the new time format.

Q Okay, now I see it is in 12-hour
format, but it doesn’t show AM 

or PM.—Carlotta

A You won’t see AM/PM if your
clock type is anything but a Plain

clock. Digital, Analog and Fuzzy themes
do not display AM/PM. Here’s a trick to
get around the problem and still use
something other than the Plain clock.
Your clock reads 1:00. Look outside. Is
it light outside? If so, then it is either
1:00 PM, or you live somewhere very
far to the north and it’s summertime
and you should really move to a place
with a warmer climate where you get
to wear shorter skirts.

Q Are you sensitive about anything
else besides being patronized

because you’re a girl?—Macho Mann

A Yes. I do not like the increasing
invasion of our privacy. Did you

ever notice how those maps in malls
and other buildings mark a place that
says “You are here”? How could 
they know that without secret hidden
cameras?�
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Mango Parfait is a Linux expert, and a cute one too;
just ask her. If you want to ask her something she
can answer for Q&A with Mango Parfait, send your
questions to mango@tuxmagazine.com.
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I’m a child of the sixties. I grew up with
movies on late-night TV, at the drive-in, in
the theatre, Super-8 home movies projected
on a portable screen—movies everywhere.
Well, not everywhere, but everywhere that
counted. As I got older, movies migrated
from late-night TV to video tape. Instead of
depending on the whim of the local TV sta-
tion, I could now go rent (and later, buy) a
movie, and watch it on TV any time. Later
still, movies transitioned to DVD and digital
file format, and with the right hardware
and software, I could even watch them on
my computer.

My laptop included a DVD drive, so the
first major test of my Linux-based laptop
was a movie. I went back to my roots,
loaded a DVD of an old “spaghetti western”
movie into my machine, sat back and re-lived
a small bit of my youth. Since then, I’ve
watched many movies on my laptop. In that
time, I’ve tried a number of video applica-
tions, and I always come back to the one 
I started with, Xine.

WHAT IS XINE?
So, what is Xine, anyway? Xine is an open-
source multimedia player for UNIX-like sys-
tems, including Linux. It can play a variety of

video and audio media, including DVDs
(assuming you have a DVD drive installed in
your computer), CDs and VCDs, as well as
video and audio media files in a variety of
common formats, including MPEG, DIVX,
Quicktime, Ogg Theora, Ogg Vorbis and
WAVe. In other words, Xine is a very versatile
audio and video multimedia player.

You can start Xine from the command line
(the program name is xine), but the usual way
to start it is from a menu. You probably will
find Xine in the Multimedia tab of your desk-
top menu, labeled as a Video Player or
Multimedia Player.

The first time you start up Xine, you are
presented with a multimedia control panel, a
video window and a setup menu. The control
panel is skinnable, and starts up in the xinetic
theme. On this panel, which looks like the
controls of a DVD player, you will find all the
controls and information you need to view
movies or listen to music.

The video window is the screen on which
the video (from your DVD, VCD or video file)
or visualization effects (generated by Xine
from your music) appears. It always starts up
with the Xine logo, which is later replaced by
the video content when you start playing your
movie or listening to your music.

Movies and More—Life with Xine
Everything you wanted to know about using the program Xine to watch DVDs on your
Linux PC, plus lots of information for people who want to tap the hidden power of Xine.

LEW PITCHER
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Figure 1. Starting Xine from the KDE Menu

Figure 2. xinetic-Themed Multimedia Control Panel
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Finally, the setup window is where you
customize Xine for your system. As a
beginner, there’s not much you can (or
need to) change, and it is fine simply to
click the Close button and dismiss the win-
dow. If you feel like changing the setup
options, you always can get the menu
back with a mouse click on the Setup 
window icon in the multimedia control
panel or by using a keyboard hot key.

Once you’ve rid yourself of the setup
menu, Xine is ready to go. From this point
on, Xine does not show the setup menu
unless you explicitly ask for it.

SO, WHAT DO YOU WANT TO WATCH?
Right from the start, Xine can play your
DVDs and CDs and (for those of you with
the technology) your VCDs. All you have to
do is put your DVD, CD or VCD into the
drive and click the corresponding button on
the multimedia control panel. Xine loads
the appropriate media driver and starts
playing your media immediately.

If hard plastic isn’t your thing and you
prefer your entertainment in files, Xine easi-
ly can accommodate your needs. The Open
Location button on the multimedia control
panel launches a file selection window so
that you can find and select the exact audio
or video file you want to experience.

Each file that you select from the Open
Location window is added to a Playlist of
files. This playlist can name files and some-
thing that the Xine developers call Media
Resource Locators or MRLs. These MRLs
are like Internet URLs; they name a selec-
tion by media and location. So, using the

Home Plate
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Figure 4. Xine’s Initial Setup Menu

Figure 3. Xine Video Window

Figure 5. xinetic Media Selection Buttons

Figure 7. xinetic Playlist Dialog

Figure 6. xinetic Open Location Dialog
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Playlist, you can set up a continuous show of files, DVD
chapters, CD tracks and network data streams.

Valid MRLs include the names of local files, in your
Linux system’s path-naming style:

� file:<path_to_file> for input from a file.

� fifo:<path_to_fifo> for input of the output of another
program.

� stdin:/ for input of the output of another program.

� dvd:/[<title>.<part>] for a DVD.

� vcd://[<CD-disk-image>|<device-
name>][@[letter]<number>] for a VCD.

� cdda://<track-number> for an audio CD.

� mms://<host>... for input from a network MMS serv-
ice.

� http://<host>... for input from a network WEB service.

� tcp://<host>:<port> for input from a network service.

� rtp://<host>:<port> for input from a network service.

� udp://<host>:<port><?iface=interface> for input
from a network service.

The last three MRL formats are used to retrieve
movies or music from Xine servers. As this implies, you
can run Xine as a server and distribute your music and
movie choices to a network for remote playback. It’s all
about control. You can control Xine’s video and audio
playback using keyboard hot keys, control panel buttons
or control panel menus. Additionally, for video files, you

can use your mouse to move between and select from
the on-screen menu options.

The control panel is fairly straightforward; playback
controls are drawn using the universally accepted sym-
bols for Play, Pause/Resume, Stop, Previous, Next and
Eject. These controls work as you’d expect them to, both
on physical media such as DVDs and CDs and on media
files played from the playlist. This window is used for
more than merely controlling the playback of your
favourite movie or music. From here, you also can repo-
sition playback using a slider; increase, decrease or mute
the sound; speed up or slow down the video playback;
take a snapshot of the contents of the video window;
maximize the video window; hide the control panel; and
quit Xine completely.

From the control panel, you also have access to several
of the Xine
menus, like the
Playlist, the Setup
window, the 
on-screen menu
navigator and
the colour and
skins control.

Xine also
provides a set of
menus as alter-
natives to the
multimedia con-
trol panel. If you
right-click on
the video win-
dow, you get a
primary menu
that provides all
the same con-
trols as the 
control panel. 

Home Plate
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Table 1. Some Xine Command Keys

Command Keystroke

Start Enter

Stop S

Pause/Resume Space

Next chapter Page Down

Previous chapter Page Up

Back Left Arrow

Forward Right Arrow

Fast Up Arrow

Slow Down Arrow

Reset speed Meta-Down Arrow

Increase volume V

Decrease volume v

Mute volume Ctrl-M

Full screen f

Xinerama full screen F

Take snapshot t

Eject e

Quit q

Figure 8. Xine’s Primary Menu
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A left-click on the video window dismisses
the menu.

Most of the Xine controls can be execut-
ed through the keyboard as well as the
mouse. This makes it easy for you to con-
trol the playback of your movie or music
without interfering with the video portion
of your entertainment. If the default key
assignments don’t suit your needs, you can
change them to your own preference
through the built-in key map editor. I’ve
listed some of the handier keyboard com-
mands in Table 1; there are more than one
hundred keyboard commands, governing all
aspects of Xine operation, and the table
lists only a few of them. Did I mention
skins? Actually, I did mention skins. Skins
are components that, when installed,
change the appearance of the Xine graphi-
cal user interface (GUI). Xine has many 
different skins that can be downloaded 
and installed on demand.

From the Settings entry in the Xine pri-
mary menu, select the Skin Downloader
option, and if you are connected to the
Internet, Xine retrieves and presents a list
of skins available for your use. As you
scroll through the list, an example of the
highlighted skin is shown in the preview
window. When you find a skin you like,
click the Load button, and the skin is
downloaded and installed immediately.

Once you have a collection of skins
loaded, you can switch between skins with-
out connecting to the Internet. From the
multimedia control panel, select the Control
button, or select the Video option from the

Xine primary menu. Xine opens a multipur-
pose window that allows you to adjust
some of the video settings (Hue, Saturation,
Brightness and Contrast) and select the skin
you want Xine to use. Remember, from this
window, you can select only a skin that you
have downloaded previously, so don’t panic
if the window shows only the xinetic skin
to start.

CHANGING XINE’S SETTINGS
You may need to change how Xine does
things. This could be because it can’t locate
your DVD or CD reader, or because the play-
back needs to be adjusted. In any case, you
want to look at the Setup menu for all these
sorts of adjustments. This is the menu we so
casually dismissed when we first started Xine,
and now we need to get it back with a click
on the Setup window button.

What Xine shows us in the Setup menu
depends on our expertise level. The GUI tab
of the Setup menu has a drop-down box list-
ing the four expertise levels, ranging from
Beginner to Master of the known universe,
with levels in between. The Beginner level can
adjust only certain superficial aspects of Xine:
things like which visualization plugin to use
for music or whether to use the Stereo 2.1
audio decoder, or which region code to use
for DVD decoding and playback.

Advanced expertise gives you more control
over the GUI and more audio parameters to
tune. It also populates several tabs that are
left empty in the Beginner level. From here,
you can adjust some of the video parameters,
as well as change the devices used for DVD,
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Figure 9. Xine Skin Downloader

Figure 10. xinetic Control Window for Skin Selection
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VCD and CD playback.
With the Expert level, you can adjust

the XVideo video overlay colour key value
used by Xine to project video onto the
Video window. This becomes necessary if
you find that the video signal bleeds into
other windows on your desktop. A change
to the colour key here makes Xine select a
different colour for the Video window
background and prevents the video image
bleed-through. Expert level also gives you
the ability to specify the location of any
Microsoft Windows DLLs that Xine can use
to decode MMS media streams with. If left
at its default, Xine looks in the

/usr/lib/win32 directory for all MMS
codecs, and this might not be the correct
directory on your system.

Finally, Master of the known universe
level gives you utter and complete com-
mand of every tunable parameter that
Xine offers. If you go this far, the effect of
any change you make is between you and
the Xine developers; most of these param-
eters aren’t meant to be changed by a
casual user.

CLOSING CREDITS
Xine is not a monolithic application; it both
includes other applications and can be
included in other applications. For most
users, the Xine package that came with
your Linux distribution has everything nec-
essary to view videos and listen to music.
On the off chance that your distribution
doesn’t include or supply Xine, you can
find it at http://xinehq.de. The Xine user
interface we’ve demonstrated isn’t the
only way to run Xine; a large number of
alternate user interfaces also are available
from http://xinehq.de, ranging from those
specifically designed for KDE and GNOME

to character-based ASCII art interfaces that
do not need X and plugin interfaces for
Web browsers.

If you run Xine under the X window
interface, you need to make sure that your
X server supports either the XVideo exten-
sion or at least supports the MIT-SHM
shared-memory extension. Both the cur-
rent X.org and XFree86 X servers support
these extensions.

Xine uses software written by other

open-source projects, including liba52,
libmpeg2, various ffmpeg decoders, libmad
and the FAAD Freeware Advanced Audio
Decoder. Your Linux distribution or Xine
package will include these packages
among its libraries. Finally, you may find
that you cannot play DVDs that have been
“protected” with the Content Scrambling
System. If this is the case, and you live in a
jurisdiction that has not outlawed the
Open Source CSS descrambling packages,
you can download and install libdvdcss
from freshmeat.net and your CSS problems
will be solved.

CURTAIN DOWN, HOUSE LIGHTS UP
So, like the hero in the movie, Xine saves
the day for Linux multimedia users by giving
them easy access to their movies and music.
If your leading character is Xine, your movie
enjoyment is virtually guaranteed.

Now, if you’ll excuse me, I’m going to
grab a bowl of popcorn and my laptop,
and spend some quality time in Deadwood
with “the man with no name”.�
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OpenOffice.org is the mainstay productivity
application of the Linux desktop. Proficiency in
OpenOffice.org directly equates to productivity
in professional life. The main components of
OpenOffice.org consist of the Writer word
processor, Calc spreadsheet and Impress pres-
entation designer. This article demonstrates
how to share information between the differ-
ent applications starting from the simplest 
of editing.

The most basic editing function is copying
and moving text around in a document. The
process of manipulating text is referred to as
cutting and pasting, or copying and pasting.
Cutting or copying and pasting of text is a sim-
ple process. Here is the copy process in a nut-
shell. Start up OpenOffice.org Writer and open
a sample document. If you don’t have any sam-
ple documents, write a few paragraphs, even if
they’re just nonsense.

THE HIGHLIGHTS
Highlight some text that you want to copy or
move. Here’s how to highlight portions of a

document, spreadsheet or what have you.
Highlighting, or selecting text, is the way the
user communicates to the computer what text
to act on. You can highlight text with the
mouse, keyboard or both.

If you want to use the mouse, move the point-
er to where you want to start the selection. Click
and hold the left mouse button, then drag the
mouse pointer over the text you want highlighted.
The text turns black as you progress. It is impor-
tant to note that you can drag the mouse forward
or backward with equal facility.

Keyboard highlighting is performed using
the keyboard, of course. Position the cursor
where you want to start highlighting. Use the
arrow keys that are found on the lower right of
nearly every PC keyboard in existence to move
the cursor. Once the cursor is in place, hold
down the left Shift key. We use the left Shift
key simply because it is easier to use two hands
for this operation. Now that the Shift is held
down, use the arrow keys to move the cursor.
The text will turn black as you progress.

Keyboard highlighting has some neat short-

cuts for quickly selecting text. Hold down the
Ctrl and Shift keys while you move the cursor
with the arrows in order to select entire words
at a time. While holding down the Shift key,
use the Page Up/Page Down keys to select
large blocks at a time. Use the Ctrl-A key 
combination to highlight the entire document.

There is a small drawback to highlighting
with the mouse. Once you get to the endpoint
and release the mouse button, you can no
longer increase or decrease your selection. This
is where keyboard highlighting comes in handy.
Try selecting some text with the mouse, and
then use the keyboard to add to the highlighted
text. The keyboard also can give you finer con-
trol over what is selected.

COPY OR CUT AND PASTE
Given any combination of the above methods
of highlighting text, highlight a section of the
text that you want to copy. Now, hold the Ctrl
key while pressing the C key at the same time
(Ctrl-C). The text is then copied to a temporary
place called the clipboard. Move the cursor to

The Cuts and Pastes of
OpenOffice.org Productivity
After a lesson on the bare basics of cut and paste, here’s how to snip a piece of
another application, like a spreadsheet, and embed it into another document
where you can continue to treat the snippet as a spreadsheet.

SCOTT STAHL
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where you want a copy of the text. Then press
the paste shortcut sequence, Ctrl-V. A copy of
the text is now in the new location.

If you want to move text, you have to high-
light the text you want moved, cut it from the
old location, and then paste it in a new loca-
tion. Try this with your sample document.
Highlight the text you want to move. Then
press Ctrl-X to cut that text. You should see the
text disappear, but it was moved into a tempo-
rary place known as the clipboard. Now move
the cursor to a new location where you want to
move the text. Press Ctrl-V to paste it there.
Voilà—you have just cut text from one location
and pasted it into another.

CONTROL PLUS
The Ctrl-then-C key combination is referred to in
print in many ways, including Control-C, Ctrl-C,
cntrl-c or even the obscure ^C. The point is simply
that you hold down the Ctrl key and then press
the C key, or whatever other key is necessary for
your Ctrl combination.

Other key combinations are written the same
way. Here is a table describing the cut and paste
keyboard shortcuts. The mnemonic at the end
may be useful, but it is by no means essential that
you memorize the combinations by the sometimes
obscure mnemonics (Table 1).

THE CLIPBOARD
You may be wondering what it means that
“The text is then copied to a temporary place
called the clipboard.” The clipboard is best
thought of as a magical place where you can
store things and retrieve them later. The catch is
that you can put only one thing in the clipboard
at a time. As we will see later, the clipboard is

capable of handling much more than merely
text, and the clipboard is not limited to
OpenOffice.org. Text placed in the clipboard is
available to any other application in KDE or
GNOME. It must be noted, however, that cer-
tain applications cannot handle the clipboard
for one reason or another. In that case, nothing
happens when you try to paste the contents of
the clipboard into an incompatible application.

The primary purpose of cut and paste may
be for editing, but the real beauty of the 
system is apparent only when you need to
aggregate small amounts of data from different
document types in one place. If you need many
different types, or simply a lot of data types, in
one document, OpenOffice.org has a Master
Document feature that is beyond the scope of
this article.

All OpenOffice applications can cut and paste
data beyond simple text. In fact, OpenOffice.org
is designed to share program functions wherever

it is possible to do so. Because of this function
sharing, the way some things get pasted may
surprise you.

A common source of data is numeric, like that
found in Calc, the OpenOffice.org spreadsheet. If
you cut or copy a selection of spreadsheet cells
from Calc and place it into another OpenOffice.org
application like Writer, what you get looks like a
table representation of the spreadsheet data. But
what you really are placing in your document is a
small version of Calc.

It is important to note that the data you paste
in the Writer document is not connected in any
way to the original document. Any changes you
make to the Calc data that is pasted in your
Writer document will not be reflected in the origi-
nal source Calc spreadsheet. Any changes you
make in the original Calc spreadsheet will not be
reflected in the data you pasted from that spread-
sheet. Once the Calc data is in the Writer docu-
ment, it no longer has any connection to the orig-
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Table 1. Cut and Paste Keyboard Shortcuts

Key Sequence Action Mnemomic

Ctrl-C Copy selected text Control Copy

Ctrl-X Cut (delete) selected text Control eXcise

Ctrl-V Paste buffered text Control View

Ctrl-A Select all text Control All

Ctrl-Z Undo last action Control Zinger
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inal spreadsheet.
You still can manipulate the spreadsheet

data you pasted into the document almost as if
you were using the Calc spreadsheet. Simply
double-click the pasted area of Calc data, and
you’ll see it transform into a spreadsheet-like
mini-window, with rows, columns and cells.
Even your toolbars at the top of Writer should
change to include Calc tools.

Here is where caution is warranted. When
you are finished modifying the Calc data, click
outside the area on a blank area of the docu-
ment or on a spot where there’s regular text.
This exits the special Calc mode and returns
the data to the form of a table. Writer will dis-
play the Calc information exactly the way you

left it. If you scrolled down a column so that
no numbers appear in the spreadsheet, no
numbers will be displayed in Writer. This
behavior is confusing at first, but
OpenOffice.org was designed this way to make
your life easier in the long run. The important
lesson here is that the default cut and paste
behavior is actually to bring a part of the 
application along with the data.

Now, we look at ways to modify the way to
paste objects or text. If you have ever used a
computer-based word processor, you probably
are aware that cutting and pasting can be
accomplished by using more than the keyboard
or mouse. We have ignored the menus until
now because they function a bit differently
than people may be used to. Don’t worry, the
basics are the same as other programs.

Choosing a feature from the Edit menu, or a
quick click of the shortcut buttons, does exact-
ly the same thing as the keyboard shortcuts.
But wait, there’s more!

Look closely at the paste shortcut button on
the toolbar (it looks like a clipboard with some
paper attached). There is a little green arrow in
the top-right corner. That arrow is there to let
you know you have more options to choose
from. You can access the other options by
what is called a long click in OpenOffice.org
parlance. Click on the toolbar button, but hold
the mouse button down until the options drop
down in the form of a menu. Don’t worry
about trying to get the mouse on the green
arrow; it works if you click anywhere on the

icon. The same options are available from the
Edit menu by choosing Paste Special.

Sometimes you do not want to bring all the
full-blown Calc features along for a few numbers
or some other trivial bit of information. Let’s look
at the Paste Special features that are available for
pasting a small column of numbers from Calc into
Writer. The Paste Special menu is aware of the
type of data on the clipboard and presents only
valid options for that data type. Our column of
numbers consists of simple text and thus has the
most features available for use. Look at the fol-
lowing list of choices on the Paste Special menu.
Don’t worry right now if some of the jargon does
not make sense, or if the list and order varies
depending on the version of OpenOffice.org
you’re using:

� OpenOffice.org Spreadsheet

� GDI Metafile

� Bitmap

� HTML (Hypertext Markup Language)

� Unformatted text

� Formatted Text (RTF)

The OpenOffice.org Spreadsheet choice is the
default behavior you see when you do a simple
cut and paste operation. Remember, this is the
choice that brings all the features of Calc along to

your Writer document.
GDI Metafile is probably the most complex

thing on the menu. Fortunately, you need to
know only what it does, not what it is. When
you paste a GDI Metafile into a document, an
image of the clipboard contents is the result.
The GDI Metafile image is scalable, meaning
that you can make it appear larger or smaller,
without losing image detail. Pasting the GDI
Metafile type works especially well in the
Impress presentation application.

The third option, Bitmap, is a rudimentary
graphics format. Bitmap graphics do not scale
well and are best left at their default pasting
size. The benefit of a bitmap is that it is a
widely used format. Nearly every other non-
OpenOffice.org application can recognize and
use a bitmap.

SUITED UP

23www.tuxmagazine.com

All OpenOffice applications can cut and paste data beyond simple text.
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The last three options are all vari-
ations on simple text objects. In each
case, you get the text with special
formatting codes. Hypertext Markup
Language (HTML) is the lingua franca
of World Wide Web pages. HTML is
designed to look good on your com-
puter Web browser screen and may
not be suitable for printed docu-
ments. The Unformatted Text option
is the lowest common denominator.
Pasting unformatted text is the exact
same thing as typing it in yourself.
The last option, Formatted Text, uses
another widely known and under-
stood document format called Rich
Text Format (RTF). Rich Text is a nice
way of preserving the table structure
along with the data in our example,
so that any cosmetic changes you
made to the data in the spreadsheet
should appear when you paste the
data into the document.

Using one of the features from
the Paste Special menu usually gives
the effect you desire.

LIVE DATA CONNECTIONS
When you cut or copy data from one
application and paste it in another,
the copy you pasted is no longer
aware of the original data. It has been
cut off from its original source and
won’t change to match any changes
you make to the original source.

Data in a document that is still
connected to its source is generally
referred to as live data. In

OpenOffice.org for Linux, cut and
paste does not give you live data
between applications, but there are
ways to achieve this feature.

The easiest way to work with live
data is to use the OpenOffice.org
Master Document type. Instead 
of trying to shoehorn data types 
to fit, simply assemble them under
one roof. You then can work on
each piece separately or even 
delegate author duties to other
people. When all the pieces are
complete, the whole thing can be
printed for a professional appear-
ance. This approach is not at all
intuitive, and it has some unfortu-
nate limitations at this point. For
example, you cannot make a
spreadsheet a part of a master
document, so this does not let you
insert a live link to an external
spreadsheet, such that any change
you make in the spreadsheet is
reflected in the master document.
Master documents currently are
designed more for constructing
books, where the sub-documents

(chapters, for example) are still
only text documents.

A more expert approach to
working with live data is to use a
database to house the information.
OpenOffice.org comes with a multi-
tude of features that allow manip-
ulation of database data. Admittedly,
these features are generally for the
power users of OpenOffice.org. This
topic deserves its own article, as it is
more complex.

As we have seen, cut and paste
can be as simple as a basic editing
feature or a gateway to much more
complex documents. We started
with the basic features that will
allow you to become productive in
OpenOffice.org immediately. Using
the basic building blocks, we then
progressed to using more complex
manipulation of data types.
Hopefully, seeing these tools will
encourage you to branch out
beyond correcting mistakes and
reordering thoughts to unleash the
productivity found in many other
OpenOffice.org features.�
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Some people really need live data, so they can paste a copy of   
some numbers from a spreadsheet into a document, and expect

the numbers in the document to reflect any changes made to the
spreadsheet. EIOffice does this extremely well. If you are open to
using a non-free office suite in addition to, or instead of
OpenOffice.org, visit http://www.evermoresw.com to see if EIOffice
could be right for you.

Tip
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One of the most common problems new users
of Linux and Windows alike encounter is that
it’s often hard to manage your folders.
Microsoft attempted to address this problem by
creating a My Documents folder where you
would store your documents by default, a My
Pictures folder and so on. The problem with
this approach is that people tend to fill up
these folders with dozens if not hundreds of
unorganized files, which makes it difficult to
find anything. The solution? Organize your files
by creating folders within folders, by category.

Most of us like to organize the data we
have. For example, you might create a Music
folder under which you will organize all your
music files (MP3 files, perhaps). You don’t want
to put all the files in that specific folder,
because it will be difficult to find the songs
you like best as it fills up. So you create more
folders within Music to sort out the songs.
Perhaps you will decide to organize your collec-
tion by music style, artist, album and file type
(MP3, wave file and so on).

Let’s say you create a Jazz folder (music type)
within your Music folder, and then create a
Steps Ahead folder (band name) within the Jazz
folder. Finally, you create a Magnetic folder

(album name) within your Steps Ahead folder.
Everything is organized neatly, so you can navi-
gate through your music files by genre, artist
and album.

Here’s the problem. Organization like this cre-
ates folders within folders within folders, and it
becomes frustrating to get to what you want
because you have to navigate through all these
folder categories over and over again.

Here’s an example of what you may want to
do to solve this problem. Perhaps Magnetic is your
favorite album for now, and you want to listen to
it frequently. Wouldn’t it be nice if you could get
instant access to the MP3 files for that album
without having to navigate through all the folders
and sub-folders you created in order to organize
your files?

It’s actually quite simple to do this without
destroying or rearranging the way you organized
your files. Simply create a folder on your desktop
that links to your Magnetic folder.

By placing links to your most common desti-
nations on your desktop, you can cut working
time and frustration down by a huge margin.
In this article, we look at desktop linking, how
it can benefit you and other ways linking can
be useful with Linux’s two main desktops, KDE

and GNOME.
For the following sections, we use the above

example for the sake of easy reading. Once you
understand the ease with which you can create
links on the desktop that point to deeply buried
folders, simply substitute your own buried folder
name for Magnetic in our example and create
your own links to your favorite folders.

Our goal is to create a link to the Magnetic
folder that appears on your desktop, so you can
open up this folder of MP3 files without having to
navigate through all the folders, for example,
Music→Jazz→Steps Ahead→Magnetic.

EXERCISE WITH KDE
Of the two desktops, KDE has the easiest method
for creating links on your desktop that point to
folders buried under the plethora of folders you
may have created to organize your files.

If you want to try this exercise with the sample
folder names we are using, here’s how to create
the set of nested folders:

1. Move the mouse pointer to an empty space on
your KDE desktop background. Click the button
on the right side of your mouse (right-click) and
hold it down until you see a menu pop up.

Linking Users with Their Data
This article describes how to make your life easier by creating links to com-
monly used folders and placing these links on your desktop for easy access.

JOHN KNIGHT
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Point your mouse to the Create New option on
the menu. This should make another menu
appear. Move the mouse to highlight Folder...,
and click the left button on your mouse. A dia-
log box pops up asking you what you want to
name this folder. Name the folder Music (unless
you already have a Music folder on the desk-
top, in which case you’ll have to choose anoth-
er name). Do not type quotes around Music;
simply enter the word Music. You never have to
type in quotes when naming folders.

2. You now should see a Music folder on your
desktop. Click on that folder with your left
mouse button. Now we’re going to repeat the
same process we described in step one. Right-
click on the empty space in the Music folder,
select Create New and then Folder. Name this
folder Jazz. Left-click the Jazz folder. Right-click
on an empty space, select Create New, and
then Folder. Name this folder Steps Ahead. Left-
click the Steps Ahead folder. Right-click on an
empty space, select Create New, then Folder.
Name this folder Magnetic.

3. Finally, close the file manager window. (You
could leave it open, because we’re about to
navigate right back to this spot, but you should
close it if you want to follow the instructions
exactly.)

You should be ready to follow the exercise exact-
ly as described in our example. If you are confident
enough with the Linux KDE Desktop, feel free to
create your own hierarchy of folders with whichever
categories you like, and then simply follow the
instructions using your own folder names.

CREATE THE DESKTOP LINK IN KDE

1. Open your home folder with Konqueror and
navigate your way through the category folders
(Music, Jazz and so on) until you get to the
folder that you want linked (in this example it
would be Magnetic).

2. Make sure you don’t navigate into the folder
named Magnetic. In our example, you would
stop navigating when you reach the Steps
Ahead folder, which contains the Magnetic
folder. The Steps Ahead folder is called the par-
ent folder to the Magnetic folder.

3. Click on the Magnetic folder with the left
mouse button, and keep holding down the
mouse button. Drag the folder from the
Konqueror window to an empty space on your
desktop and then release the mouse button.

4. A dialog box now pops up with the options:
Copy Here, Move Here and Link Here. Choose
Link Here, and you now should have a desktop
shortcut that points to Magnetic. Now, when-
ever you want to get to those particular song
files, all you have to do is click on the desktop
link. It is no longer necessary to wade through
multiple folders and categories to get to this
album.

GNOME
GNOME has a slightly more difficult method and
is covered here in two parts: linking from a Linux
filesystem and linking from a Windows filesystem.

1. Open up your home folder with Nautilus, and navi-
gate your way to a folder that is buried—some-
thing like the Steps Ahead folder in our example.
You should see the Magnetic folder there (or
whichever folder you plan to link instead).
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Figure 1. The Ease of Creating Links with KDE Figure 2. The newly created link before its final
destination with Nautlius.
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2. Right-click on the Magnetic folder, and choose
Make Link from the pop-up menu.

3. Nautilus now creates a new folder called link to
Magnetic and places it in the same folder as
the original. Left-click and hold down the
mouse button, and drag the new folder called
link to Magnetic onto the desktop. You should
now have a desktop shortcut under GNOME to
your favorite album.

FURTHER USES
Linking isn’t purely for making shortcuts to com-
mon folders on the desktop, it has many other
uses too.

Linking to your home directory can be just as
advantageous, if not more so, than linking to your
desktop. With links in your home directory, you
can access your most important files and folders
quickly from any window manager, any file man-
ager and even from the command line. Whenever
I install Linux, the first thing I do is make home
directory links to my most important folders; this
makes the process of getting off the ground much
quicker and easier.

In order to make a home directory link, simply
follow the steps for making desktop links, but
open a new window with your home directory and
drag the file or folder into your home directory’s
window, instead of onto the desktop.

LINKING FILES
So far, we’ve covered only linking folders, or direc-
tories (they’re the same thing, folder is simply a
GUI term for a directory), but you also can link
files using exactly the same method described
above. Linking files can be useful for all kinds of
things, like accessing a file that is used daily or

simply having a file in two places at once,
whether it be for working on it from several dif-
ferent places or for having a file exist with two
different names. This kind of usage can be handy
when it comes to programs and their configura-
tion files, but this is quite advanced and beyond
the scope of this article.

RECOMMENDATIONS
When it comes to linking to your home directory, I
recommend linking only folders, and only the most
commonly used folders at that. Home directories
can get cluttered very quickly; moving around in a
file manager with a cluttered home directory can
defeat the whole purpose of linking in the first
place. For files or folders that you use a lot, but
only temporarily, try linking them to the desktop
instead. If what you are chasing is only a folder or
so away, it may not be worth a link and may just
be taking up space, but a file or folder that’s many
folders down the chain is certainly worth linking to.

If you have a file or folder that you are using
everyday for the moment, it’s definitely worth
making a desktop link, especially if it’s buried
deep under a lot of folders, as mentioned earlier.
If this file or folder is likely to be used often, it’s
worth making a link from your home directory as
well. If the link you are making is being accessed
under a number of programs as well, then a
home directory link is far more useful then a desk-
top link, as the desktop’s directory is harder to get
to than your home directory (home is usually the
first directory brought up by any program).

By now you should have a number of uses for
linking and at the very least, you’ll find your hard
disk more organized and more efficient. When it
comes to linking, Konqueror is certainly the better
choice, as linking from a Windows filesystem isn’t a

problem due to its simple and elegant process for
copying/moving/linking. The problem in Nautilus is
simply a design flaw that hopefully will be changed
in future. GNOME users can still link from a
Windows filesystem with other methods though,
such as using the command line, or even by firing
up Konqueror under GNOME (but these are also
beyond the scope of this article). In the meantime,
try experimenting with linking as much as you can,
and this should take you a step further into making
your Linux environment truly comfortable.�
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Q&A

Q Why can’t I link from a Windows filesystem
using GNOME/Nautilus, yet I can do it

under KDE?

A In order to make links, Linux uses a method
called symbolic linking. However, symbolic linking

is supported only under Linux/UNIX filesystems and not
under Windows. When Konqueror links a file, it simply
tries to make a link at the final destination (like the
desktop); when Nautilus makes a link, it makes a link in
the same place that the parent folder resides, which
you then move to the final destination. If this happens
on a Windows filesystem, it canít make the link to
begin with and therefore comes up with an error.

John Knight is a 20-year-old rock-climb-
ing, Japan-loving megalomaniac, trying
to take over the world from his bedroom
via his keyboard. He spends most of his
time tinkering with MPlayer and head-
banging to his MP3s.
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Computer users spend a lot of time working with
their files: creating and editing them, figuring out
where to put them, changing their names, copy-
ing and moving them to different locations, get-
ting rid of ones they don’t need anymore and so
on. Modern user environments typically provide
tools for working with folders and files. Linux is
no exception, and its Konqueror file manager
application is both powerful and simple to use. In
fact, Konqueror also functions as a Web browser,
thereby providing a single interface for two sepa-
rate activities (and, in fact, it supports several oth-
ers as well).

GETTING ACQUAINTED WITH KONQUEROR
You can open the Konqueror application in several
ways. For example, you can double-click on the
Konqueror or home directory icon typically found
on the desktop. Once it is opened, a window like
the one shown in Figure 1 appears.

This window is divided into several distinct
parts:

� The usual menu bar along the top of the win-
dow.

� A series of one or more toolbars underneath
the menu bar. In Figure 1, there are two tool-
bars present: the Main toolbar and the Location
toolbar. The Main toolbar contains icons for
many common tasks. The Location toolbar dis-
plays the directory (folder) whose contents cur-
rently are displayed in the window’s main area.
This toolbar also can be used to navigate to a
different directory or Web page by typing in the
desired location. Directory paths are preceded
by the string file: (just as World Wide Web loca-

Be the Master of All You Survey: 
Using Konqueror for File
Management and Domination
Konqueror is so feature-rich that it sometimes can be intimidating. Æleen Frisch sorts out the basics and some
advanced features with this comprehensive look at how you can manage your folders and files with Konqueror.

ÆLEEN FRISCH

Figure 1. The
Konqueror

File Manager
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tions are preceded by http:).

� The vertical toolbar and folder list display along
the left side of the window is known as the
Navigation panel. The icons in its toolbar per-
form various navigation-related tasks, and the
somewhat narrow display area can show a tree-
like view of the folder hierarchy. The panel can
be displayed or not displayed, as desired.

� The main display area in the window shows the
contents of the current location, in this case,
the files within the current directory. The cur-
rent display mode is icon view, in which various
files and subdirectories are displayed as icons.
Other display modes also are supported, as we
will see.

� The display area contains two tabs, each of
which shows the contents of a different direc-
tory. In addition to supporting multiple displays
via separate tabs, this area also can be divided
into multiple sub-windows, arranged either hor-
izontally or vertically.

The callout text within Figure 1 provides a
quick reference to the functions of the many icons
found within the Konqueror window. At any time,
you can get more detailed help about a window
control or section using the Help→What’s This
menu path or the Shift-F1 key combination. Doing
either causes the cursor to change appearance to
include a small question mark. At this point, you
can click on the item for which you want help,
and detailed information about it is displayed.

MAIN TOOLBAR AND NAVIGATION PANEL ICONS
Many of the icons on the Main toolbar should be

familiar to you. For example, the first six icons typ-
ically are found in the same location on the tool-
bar for most Web browsers. In the context of file
browsing, a couple of them function slightly dif-
ferently. For example, although the Back and
Forward buttons change the display to the previ-
ous/next location as they do when browsing the
Web, the Up button changes the displayed direc-
tory to the folder immediately above the current
one in the directory tree. The Home button dis-
plays the contents of your home directory by
default (unless you configure Konqueror different-
ly). The Cut, Copy and Paste buttons also function
slightly differently. When one or more items is
selected and you click Cut or Copy, those items
are moved or copied to the clipboard. The Paste
button copies any item(s) on the clipboard to the
current directory location. In both cases, the items
themselves are what is copied and pasted, not
merely their contents.

The tab icons create a new tab within the dis-
play area and close the current tab, respectively
(see the icons labeled New Tab and Close Tab in
Figure 1). The magnifying glass icons with the plus
and minus signs on their lower left sides change
the size of icons within the display area, making
them larger or smaller, respectively. The Icon View
and List View buttons cause each item to be dis-
played as an icon or as a line within a list of items.

Most of the icons on the Navigation panel are
easy to understand. However, one of them
requires a bit of explanation. The icon labeled
Root Directory in Figure 1 toggles the display of
the folder tree, removing or restoring it with each
click. When the display is present, it shows the
contents of the entire folder hierarchy on the 
system.

EXTRA TOOLBAR
Selecting the Settings→Toolbars→Show Extra
Toolbar menu item causes an additional toolbar,
known as the Extra Toolbar, to be displayed.
When Konqueror is being used as a file browser,
this toolbar looks like the one shown in Figure 2.

Figure 2. Extra Toolbar

Moving from left to right in Figure 2, these
icons open and close the Navigation panel, open
the Find File facility (discussed below), split the
display area into two sub-windows (arranged hori-
zontally or vertically), close the current sub-win-
dow (known as the active view), toggle the dis-
play of icon previews (for example, tiny displays of
the actual contents of a picture file rather than
merely a generic icon for that file type) and open
the View Filter dialog (see below).

MOVING AROUND
There are several ways to move to a different
directory location within Konqueror. For example,
you can use the Location Toolbar to specify the
desired location. You also can navigate using the
Navigation panel’s directory tree view. Clicking on
a folder causes the items within it to appear with-
in the display area (more specifically, within the
currently active view/tab). The tree can be expand-
ed and contracted by clicking on the minus and
plus signs to the left of folder names. The items
on the Go menu also can be used for navigation
purposes. Several commonly used destinations are
included as items within it. The Go menu also
contains two useful submenus: a list of Most
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Often Visited directories and a List of Recent
Places. Finally, you can create Bookmarks for direc-
tory locations just as you do within a Web brows-
er for Web sites. The Bookmarks menu provides
features for accomplishing this.

BEING IN MORE THAN ONE PLACE AT THE SAME
TIME
Konqueror provides three different mechanisms
for viewing multiple folders at the same time:

� Separate windows: you can open a new
Konqueror window using the Location→New
Window menu item (or by pressing Ctrl-N).
Each window operates independently.

� Using tabs: you can have multiple display areas
within a single Konqueror window by using
tabs. The New Tab item on the Window menu
creates a new tab, pointing to the same direc-
tory as the current tab, as does the key combi-
nation Ctrl-Shift-N or the corresponding item
on the Main toolbar. You can close the current
tab with Ctrl-W or Window→Close Current Tab
or by using the Toolbar icon. You can cycle
among tabs from the keyboard with Ctrl-]
(move to the previous tab) and Ctrl-[ (move to
the next tab). Other operations are available on
the Window menu.

� Split views: you also can divide the display
area—whether or not you’re using tabs—to
create separate sub-windows called views. You
can divide the area into two (or more) horizon-
tally or vertically arranged panes. In fact, you
can create arbitrarily complex layouts of view
panes, because each time you perform a divi-
sion operation, it operates only on the active

view. Take a bit of time to play around with this
feature to learn how it works. Figure 5 displays
a Konqueror window with two views.

CONTROLLING WHAT YOU SEE
Konqueror has many options for displaying the
items within a directory. The first main distinction
is between an icon view and a list view, and there
are icons on the Name toolbar that switch
between them. However, Konqueror actually
offers two different list view formats, accessible
via the View→View Mode slide-off menu’s Info
List View and Detail List View items. The List View
icon on the Main toolbar uses whichever of these
list view forms has been selected most recently.
Figure 3 shows the detailed list view provided by
Konqueror. For each file and folder within a direc-
tory, the display includes the item name, size,
type, most recent modification date, permission

settings, owner, group owner and link target if
the item is a symbolic link. You can click on any of
the headings to sort the list based upon that item.
The first click sorts the list in ascending order for
that item—that is, alphabetically for names, from
smallest to largest for numbers and dates and so
on—and the next click sorts the list in descending
order.

You also can control whether hidden files are
included within the display using the View→Show
Hidden Files menu item. If hidden files are dis-
played, their icons/entries indicate their status by
dimming. For example, see the folder .xvpics
shown in Figure 1.

Konqueror also includes a much more detailed
way of controlling which files are displayed. This is
known as the View Filter, and you can open it
using the Tools→View Filter slide-off menu or by
clicking on the corresponding icon on the Extra
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menu. In either case, the Only Show Items of Type
menu appears (Figure 4).

Figure 4. Only Show Items of Type Menu

The items in the first two sections of the list
shown in Figure 4 consist of all of the different file
and folder types that are present within the cur-
rent directory. In this case, there are three differ-
ent types of files, including two different types of
images, as well as one or more ordinary subdirec-
tories. The Use Multiple Filters item controls
whether items of more than one type are dis-
played; it is checked by default.

You can use this dialog by selecting one or
more item types from the list. As you do so, the
items in the display area appear and disappear to
conform with your specification. The Show Count
item within this menu causes the number of items
of each type to be displayed within the menu list.

LINKING AND LOCKING VIEWS
When you are using more than one view, you can

choose to link multiple views together so that
changing the current directory within one of them
causes the same change to occur within the other
automatically. For example, you might create two
views stacked on top of one another and set them
both in the same folder. One of them might dis-
play the items in icon view while the other dis-
plays them as a detailed list. Linking them retains
the same two views whenever you change the
current directory in either one.

You can link views using the small check
box in the lower-right corner of the view sub-
window. Clearing the check box causes the link
to be broken.

The View menu’s Lock to Current Location item
causes the current directory in the active view to
be locked, preventing you from accidentally
changing it. This can be useful if there is a directo-
ry with contents you want to examine often. For
example, I frequently create a tab pointing to the
directory in which I’m currently working and then
lock it.

WORKING WITH FILES AND FOLDERS
Konqueror makes it easy to work with files and
folders. In this section, I briefly summarize the
most common operations you might want to per-
form:

� Selecting items: clicking on an item selects it,
changing its appearance (see the save item in
Figure 1, for example). You can select multiple
contiguous items by holding down the Shift key
as you click on icons or create a marquee around
a group of icons. To select a random collection
of icons, hold down the Ctrl key as you select
them. You also can use the Ctrl-A key combina-
tion to select all of the items within the display.

� View item properties: these can be displayed
for a selected item by pressing Alt-Return.
Alternatively, you can right-click on an item
and then select Properties from the resulting
context menu.

� Opening an item: there are many ways to open
an item. For example, you can double-click on
its icon or select its icon and then press the
Return key. If you want to choose which appli-
cation is used to open the item, right-click on it
and choose Open With.

� Creating a new folder: you can create a new
folder (subdirectory) within the current directory
by pressing the F10 key. More generally, you
can create a new item of many different types
using the Edit→Create New menu item or by
right-clicking in a blank area of the current view
and then selecting Create New.

� Renaming an item: the simplest way to rename
an item is to click the cursor within its name,
wait until the name text is selected, and then
type the new name. You also can use the
Edit→Rename menu path or the F2 key to per-
form the same operation.

� Deleting an item: Konqueror provides three dif-
ferent ways of removing a file or folder.
Selecting one or more items and then pressing
the Delete key (or choosing Edit→Move to
Trash) moves those items to the trash (where
they remain until you empty it). If you want to
delete the items immediately, you can use the
Shift-Delete key combination instead (or choose
Edit→Delete). Finally, if you want to delete the
item immediately and attempt to obliterate all
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traces of it from the disk, use the Ctrl-Shift-
Delete key combination (or Edit→Shred). This
latter operation writes data to those disk areas
previously used by the items several times.

� Copying and moving items: Konqueror does
an especially good job of copying and mov-
ing items between folders. Once again, there
are many ways to accomplish these opera-
tions. One of the simplest is to divide the dis-
play area into two views: one for the current
location of the items and another for the
location where you want to copy or move
them. Once you have done this, you simply
can select the desired items within their cur-
rent location and drag them into the other

view. This operation is shown in Figure 5.

Once you let go of the items, a menu appears
containing the following choices: Copy Here,
Move Here, Link Here and Cancel. At this point,
you can select the item that corresponds to what
you want to do: create a copy of the items, move
the items from their old location to this new one,
create a symbolic link for each item within the tar-
get folder or cancel the operation. There are other
ways to copy and move files. For example, you
can select the desired items and then press F7 to
copy them or press F8 to move them (the
Edit→Copy Files and Edit→Move Files menu items
perform the same tasks). In addition, you can use
the familiar cut and paste functions to move items

(using copy instead of cut
if that is what you want).

LOCATING ITEMS
Sometimes things get
lost. When a file is lost,
Konqueror can help. The
Tools→Find File menu
path (or the correspon-
ding icon on the Extra
Menu) results in the 
dialog shown in Figure 6.
This dialog has three
panels; the various 
panels are all displayed
within the figure,
arranged vertically.

As the panels in the
illustration indicate, this
feature provides a rich
and detailed set of search
criteria. You can specify as

few or as many different attributes of the item
you are looking for as you want. If more than one
is used, the search looks for items that match all
of them.

The Name/Location panel holds the full or
partial name of the item that you are looking
for, as well as where the search should begin.
In the example in Figure 6, I’m looking for a
lost picture of an armadillo, so I specify the
partial name arma* (the asterisk serves as a
wild card). I also include the directory where I
want the search to start; in my case, the search
starts at /stuff and includes the entire directory
tree underneath it.

The Contents panel specifies characteristics
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Figure 6. The Find File Dialog
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of the item for which you’re searching. In my case, I am
looking for a TIFF image file. The File type pop-up contains a
large number of possibilities, but do you not have to specify
the item type at all if you don’t want to. The Containing text
field allows you to search within text files for a certain string
or expression.

The Properties panel specifies the date, size and owner-
ship for the desired item. Here, I’m looking for a version of
the file modified during the past 18 months (when I per-
formed the search, I could find only a five-year-old version
of the image I wanted).

Once you have filled out all of the relevant fields, you can
start the search, and Konqueror displays matching items. In my
case, it succeeded in locating the file I wanted, which was deep
within the directory tree in a folder called Old_Pix.

EXPLORE MORE ON YOUR OWN
I hope that this introduction to Konqueror is useful to you and
that you are now aware of its extensive capabilities in terms of
file and folder management. The Quick Reference table summa-
rizes the menu path and key combinations for the most com-
monly performed Konqueror tasks. Like most Linux applications,
Konqueror also can be customized; see the various items on the
Settings menu. In addition, don’t forget to have fun as you
explore Konqueror on your own.�
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Konqueror Quick Reference

Konqueror Operation Key Combination Menu Path

Go to your home directory Ctrl-Home Go→Home

Select all items in window Ctrl-A Edit→Select All

Show item properties Alt-Return Edit→Properties

Rename item F2 Edit→Rename

Print selected file Ctrl-P Location→Print

Copy selected files F7 Edit→Copy Files

Move selected files F8 Edit→Move Files

Create a new directory F10 Edit→New Directory

Move to Trash Delete Edit→Move to Trash

Immediately delete Shift-Delete Edit→Delete

Delete and erase from disk Ctrl-Shift-Delete Edit→Shred

Open new window Ctrl-N Location→New Window

Split window vertically Ctrl-Shift-T Window→Split View Top/Bottom

Split window horizontally Ctrl-Shift-L Window→Split View Left/Right

Remove active portion of a split window Ctrl-Shift-R Window→Remove Active View

Create new tab Ctrl-Shift-N Window→New Tab

Move to the previous/next tab Ctrl-[, Ctrl-] n/a

Close the active tab Ctrl-W Window→Close Current Tab

Detach the active tab as a separate window Ctrl-Shift-B Window→Detach Current Tab

Display the navigation panel F9 Window→Show Navigation Panel

Get help on a window item Shift-F1 Help→What’s This
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The first generation of computer screens could be
damaged by displaying the same image for long
periods of time. In a few days, the image would
burn a ghost-like replica of itself into the screen.
The image always would remain a distraction in
the background.

This led to the creation of screensavers.
Screensavers are simple programs that generate a
sequence of ever-changing graphics. The fact that
the image changes frequently prevents any single
image from being displayed long enough to burn
a ghost of itself onto the screen.

Advances in technology have made computer
screens far more resistant to ghosting. The original
problem has almost disappeared: any modern
monitor can display the same static image for
months before starting to “remember” it.

In spite of this, screensavers are far from dead,
for a couple of excellent reasons.

The first reason is that they can all lock a
computer, that is, hide all the windows, inhibit
the keyboard and be stopped only by typing the
password of the user who started them. In some
companies, a locking screensaver is mandatory.
This helps to prevent janitors, night guards, mail
carriers and similar high-tech criminals from
stealing precious company intelligence. Even at

home, however, a locked screensaver can be
very useful. If you don’t believe me, just leave
your PC unattended, halfway through on-line
shopping, while children are around: it will take
only a few seconds to max out your credit card
and leave you the dubious owner of items you
never knew existed.

The second big reason to use a screensaver
is, of course, the same reason we want to have
different clothes, cell-phone ring tones or e-mail
signatures—to look cool and unique, right?

SOME GOTCHAS
There are some possible drawbacks to using
screensavers. First of all, the more graphic-inten-
sive a screensaver is, the more CPU cycles it uses
to run. Other programs that you have running in
the background might run more slowly (but there
is a fix to that).

In some extreme cases, your machine could
become hotter, or noisier, if the fans ramp up to
cool the processor that is refreshing (ah, the irony)
your screen. On a laptop, batteries would dis-
charge more rapidly. Thus, you may not want to
use, or temporarily deactivate screensavers, if you
have cooling problems, battery limitations or
something really urgent to do. In addition, many

All about Screensavers, and
Why You Want to Run Them
Once necessary to protect hardware, today’s screensaver is mostly just cool.

MARCO FIORETTI

DPMS

The standard used to tell a monitor when and
how to save power is called Display Power
Management Signaling, or DPMS for short.
Here’s how to make your KDE 3.4 screen
aware of DPMS. (The method is similar in ear-
lier versions of KDE, so you should be able to
find your way around even if you’re not using
version 3.4.) Point to an empty area on your
KDE desktop and click the right mouse but-
ton. Select and left-click on the Configure
Desktop menu selection in the pop-up menu
that appears. Click on the Screen Saver icon
on the left-hand side of the dialog box that
appears. Click the box that says Make aware
of power management. That’s it; you’re done.
More advanced users can set DPMS options
using the xset command from the command
line. Depending on the distribution, simply
look through the documentation for some
power- or DPMS-related entries.
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modern monitors have some energy-saving capa-
bilities to reduce power consumption. Forcing
them to display a screensaver prevents them from
going into low-power standby mode. Fortunately,
you usually can configure your desktop, such as
KDE, to display the screensaver for a while, after
which it automatically blanks the screen and puts
it in low-power mode.

Last but not least, here’s some embarrassment-
prevention advice. You can set many systems to
random screensaver mode. This lets the system
choose which screensaver to start randomly. This
is very cool, but think before activating it. Trust
me when I say so. I chose random mode once on
my office workstation, and it happily started a 3-D
rotating model of the Viagra molecule, titled with
128-point font size, right when my boss entered
the room.

WHAT IS A SCREENSAVER ANYWAY?
A screensaver is any independent program that
can draw something on screen. Normally, screen-
savers never are invoked directly, and each one
has many options to customize its behavior.

SETTING UP SCREENSAVERS IN KDE
The KDE screensaver panel is inside the
Appearance/Sub Themes menu of the KDE
Control Center. You can preview a screensaver
simply by clicking on its name. Each has different
options. To check and change the options, click
on the Setup... button. To see full-screen what the
result will look like, click Test.

In this panel, you also can configure general
parameters. This where you tell KDE if the screen-
saver should be started automatically, after how
many minutes of inactivity it should start or
whether a password is needed to go back to the

system. You also can set a grace period, that is,
for how long, after the screensaver is started, a
password is not required to stop it. This allows

you to adjust your PC behavior to match your
habits and level of paranoia exactly. For example,
often I temporarily stop using the keyboard and
mouse to consult some manual or other paper
document. Without a grace period, I’d have to
retype the password every time the screensaver
starts. With the grace period, as soon as I notice
that the screensaver started, I touch the mouse to
reset it. Of course, if you start the screensaver
deliberately, by clicking on the lock icon in the
panel, there won’t be any grace period.

The default KDE selection offers screensavers of
all types. With the several banners, for example,
you can type in your own message or inspirational
quotation (like “Time to go back to work!”),
which will then move across the screen with the
color and speed of your choice. The Banners and
Pictures section also includes a Slideshow feature.
Simply tell it in which folder your picture gallery is,
and it merrily cycles through them. There are many
more categories waiting for you to discover them.
The KDE screensavers are in a separate package
called KDE-artwork, which might be missing if you
had a custom/minimal installation. Once they’re
installed, the control center knows which screen-
saver to list by looking for text files with the
.desktop extension in the proper folder. (On the
Fedora Core distribution, this is in /usr/share/
applnk/System/ScreenSavers.)

This comes in handy when you want to remove
a particular screensaver—for example, because it
is not suitable for children or a work environment.
The only thing you need to do is find the corre-
sponding .desktop file and rename it to some-
thing with a different extension. This won’t pre-
vent other users from launching the screensaver
by hand, but frankly, if they know how to do this,
the .desktop trick wouldn’t change much anyway.
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Figure 1. KDE Screensaver

Figure 2. KDE Hypercube
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To reenable the screensaver, simply give the
file its original name.

GNOME AND XSCREENSAVER
The GNOME desktop uses the popular pro-
gram Xscreensaver for managing this part of
your system. It comes with a lot of screen-
savers, including one, called VidWhacker,
which grabs video frames from the system’s
video input and then uses some graphics fil-
ters chosen at random to manipulate and
recombine them in various ways. Even if it is
laid out differently, the functionality of the
GNOME interface to Xscreensaver is almost
identical to the one in KDE. There is a list of
the available screensavers, a preview window
and a separate pop-up panel to modify, at
will, all the available options for each hack.
In GNOME’s Xscreensaver, the binary pro-
grams are (again, on Fedora Core) in
/usr/X11R6/lib/xscreensaver/, and the config-
uration files read by the GNOME Control
Center in /usr/share/control-center/
screensavers/. Beware that this time they
have an .xml extension. Yes, there is some
unnecessary duplication here. Hopefully, it
will be removed in future distributions. The
procedure to hide an unwanted hack is the

same as with KDE; that is, remove or rename
the configuration file that corresponds to the
unwanted screensaver.

WHERE TO GET MORE SCREENSAVERS?
For more recent and snappier screensavers
check out the http://rss-glx.sourceforge.net,
http://www.linuxhotbox.com and
http://www.uselinuxathome.com/
ENkdelook.htm pages. The latter also has a
newsletter that notifies you when new screen-
savers are available. Oh, before I forget—do
you have friends, stuck on Windows, who
want (or need) to see that Linux is as GUI as
they come? Surf over to http://www.pippo.com/
linux-saver.html. That program (optimized
for 800x600 resolution) will display nice
Linux desktop screenshots to users who
desperately need them. The author wel-
comes more contributions!�
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Figure 3. Xscreensaver

Figure 4. Xscreensaver Preferences

Marco Fioretti is a hardware sys-
tems engineer interested in free
software both as an EDA platform
and, as the current leader of the
RULE Project, as an efficient desk-
top. Marco lives with his family in
Rome, Italy.

Using DPMS: http://grebowiec.net/archives/2004/10/linux_desktop_u_1.html
Using DPMS to Reduce Your Power Bill: http://linuxreviews.org/howtos/power/xorg_dpms
Xscreensaver: http://www.jwz.org/xscreensaver
Sunsite Screensavers Section: ftp://sunsite.unc.edu/pub/Linux/X11/screensavers

RESOURCES

http://rss-glx.sourceforge.net
http://www.linuxhotbox.com
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http://www.pippo.com/
http://grebowiec.net/archives/2004/10/linux_desktop_u_1.html
http://linuxreviews.org/howtos/power/xorg_dpms
http://www.jwz.org/xscreensaver
ftp://sunsite.unc.edu/pub/Linux/X11/screensavers
http://www.uselinuxathome.com/ENkdelook.htm
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http://www.tuxmagazine.com


This article provides you with a
must-have list of tips every GIMP
Guru needs. Don’t worry about
which version of GIMP you’re using.
All of these tips apply to GIMP 2.0,
the latest version and the one most
users will see in new Linux distribu-
tions. But, most also apply to GIMP
1.2, which has been the staple of
Linux distributions for many years.
I’ll be sure to point out any version-
specific issues.

The GIMP can feel intimidating
with its feature-rich environment,
but nearly every common graphics
task is little more than a couple of
fast mouse clicks away.

FAST FILLS
Need color in a big way? Drag and
drop, my friend. The foreground
and background colors can be
dragged into any canvas or selec-
tion for a quick color fill. Better
yet, saved colors can be dragged
and dropped too. How do you save
colors? The Palette dialog is one
place. Open the Palette dialog and
drag any color into your canvas for

instant color.
GIMP 1.2 users: the Watercolor

tab in the Color Selection Dialog
can save colors. Select a color,
then click New in this tab to save
it to the History boxes. Then, you
can drag any History box to your
selection or canvas.

GIMP 2.0 users: the Change
Foreground/Background Color
Dialog has history boxes too. Click
the right-facing arrow next to the
history boxes to save the current
color. Then drag the current color
to your selection. GIMP 2.0 has
the added bonus of allowing you
to drag patterns into any selection
or Canvas window too!

FAST EXPORT
The quickest way to turn a layer
into an image on its own is to
drag it from the Layers and
Channels dialog to the Toolbox.
This little trick is so easy it doesn’t
even need an example. Try it with
one of your multilayered images,
which you’ve saved in the XCF for-
mat, right? The XCF format is The

GIMP’s native format, so files
saved in this format preserve all
the features The GIMP has to
offer. It is a good idea to save all
your GIMP images in XCF format
until you’re ready to use them in a
Web page or other application,
after which you can export the
image to whatever format suits
you—PNG, JPEG and so on.

FAST DRAW
Straight lines can be drawn with any
paint tool. Click once to set one end
point. Shift-Click to draw a straight
line to the second end point. Use
Shift-Ctrl to view lines at offsets of
15 degrees, and then click to draw
the line. Primitive shapes need only
an outline and a stroke applied.
Outlines can be drawn by first set-
ting guides, using the Path tool
(GIMP 2.0) or Bezier tool (GIMP 1.2)
to create the selection.

FAST LOGOS
So, what about something more
complex? How about ready-to-rock
logos? The GIMP comes with a

Going Guru: Michael’s Top GIMP Tips
It’s a new day in a new world on the Linux Desktop. And like every good morning, we want to dive in and get things
done. The GIMP makes our life easy, if we just remember a few great tricks of the trade.

MICHAEL J. HAMMEL
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Figure 1. GIMP 1.2 uses the
Watercolor tab for color histories to
do drag and fill.

Figure 2. GIMP 2.0 has histories right
up front, but it drags from the
Current Color bar instead of the his-
tory buttons.

TUX EXPLAINS
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plethora of logo designs ready to
run. All you need to add is some
text, a color or two, and a font.

All the GIMP logos are found in
the Xtns→Script Fu→Logos menu
in both GIMP 1.2 and GIMP 2.0.
For the more adventurous, and
assuming you can stomach the
scripting language (a form of
Scheme), all logo scripts can be
modified to your own taste.

FAST SHADOWS
The effect with the most impact and
the least effort has got to be shad-

ows. These are found under Script-
Fu→Shadow in both versions. The
Drop Shadow in particular can take
your ordinary graphic and make it
stand out in 3-D with only two
mouse clicks.

FAST TINTING
The GIMP doesn’t do duotone,
which is a bummer. But, you can get
the next best thing with judicious

use of blend modes. Mixing some
color in various ways with a desatu-
rated image that has been converted
to indexed mode and then back to
RGB mode gets you pretty close to
what you need.

Converting to Indexed one more
time after tinting also can enhance
the effect, but the final choice
depends on the original image and
your own artistic flair.

The print version of these images
can’t be guaranteed to be exactly
correct, because CMYK isn’t support-
ed in The GIMP yet. But, if you can
get the RGB equivalents of Pantone
colors, your print results will be close
to the Pantone color selected.

FAST TESTING
If you’re not into building animations
with The GIMP, you may not have
run across this little jewel. The
Animation→Playback filter lets you
drag an image from its window onto
any other window. You can use this
feature to test how an image will
look on your Web site by simply lay-
ing it over the browser window.

The really nifty part of this is that
transparent images work too. No
more regenerating Web pages and
making sure your sizes are explicitly
specified—simply drag the image
over the browser to sample it.

TUX EXPLAINS
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Figure 3. Click on guide intersec-
tions with the Bezier tool in GIMP 1.2
to define the shape, then click inside
the shape to create a selection.
Select a paint tool and brush and
use Edit→Stroke to draw the shape.

Figure 4. Click on guide intersec-
tions with the Path tool in GIMP 2.0
to define the shape. Then click on
the Create Selection From Path but-
ton. Edit→Stroke Selection is used
to draw the shape, using either the
current paint tool and brush or one
of the user-defined stroke options.

Figure 5. The dialog windows for
Logos are nearly identical for GIMP
1.2 and GIMP 2.0. Learning one will
get you through the other.

Figure 6. Font selections work basi-
cally the same in both versions.
Getting fonts recognized by GIMP
versions differs, however. GIMP 1.2
looks to the xfs server to provide
fonts (try typing man xfs for help).
GIMP 2.0 looks to FontConfig (see the
fc-cache and fc-list commands for
help here).

http://www.tuxmagazine.com


FAST PREVIEWS
If you recently uploaded a collection
of JPEGs from your camera and
want to get a collection of previews
from those really fast, The GIMP
makes it easy. Select File→Open in
either version of The GIMP. The File
Selection dialog lists all the images
in the right side of the window
pane. Click on the top-most entry,
then hold down the Shift key while
clicking on the bottom-most entry.
Finally, click on Preview area.
Thumbnail previews are generated
for all the selected images.

If you’re a bit of a developer, it
wouldn’t be hard to open these

thumbnails and create instant contact
sheets. Producing a WYSIWYG sheet
would require a bit of work—nothing
more than a short GIMP Perl or even
a ScriptFU script.

FAST GRADIENTS
Gradients are heavily used to simu-
late depth in images. Draw a circle
and fill with a radial gradient—white
to black works best—to create a
sphere. Gradients, however, use a
lot of color. Trying to map one down
to the few colors that are known to
be Web-safe produces the all too
familiar banding—lines of color 
that destroy the effect gradients
provide.

So, how do you fix this problem?

TUX EXPLAINS
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Figure 7. Not much has changed
with default textures from 1.2 to 2.0.
A couple extra textures are provided
with 2.0, but you may want to add
your own. They can be saved in any
directory, but both versions default
to looking somewhere under the
ScriptFu directories.

Figure 8. The outline of a mouse
takes on three dimensions with the
simple addition of a drop shadow, 4
pixels offset and with a 4 pixel blur. A
more complex example shows a per-
spective shadow under a sphere
(made with a circular selection and a
radial gradient—and nothing more). Figure 9. The first method of tinting

an image is to desaturate an image
and convert it to Indexed Mode. Map
the number of colors to a very low
amount, perhaps four to ten colors in
the Indexed palette. This gets you the
duotone appearance and leaves
enough grayscale pixels to allow you
to tint the image. Change back to
RGB mode (so you can properly tint
the image). Duplicate this layer one
to three times. With each new layer
do Ctrl-A to select everything, choose
a color, set the blend mode to Color
for the Bucket Fill tool and click on
the canvas. The gray pixels are tint-
ed. Repeat this on the other layers
with other colors, and apply each
layer with different layer modes.

Figure 10. An alternative method to
tinting an image is to use a layer that
is fully colored and apply it using
layer blend modes to the desaturated
(but untinted) layer. This method has
the advantage of not changing the
desaturated layers’ pixels and mak-
ing use of compositing features of
The GIMP to achieve the results
you’re after. Depending on the origi-
nal layer, modes like Multiple,
Overlay, Screen and Hard Light
(among others) can help bring out
detail in the image.
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Nothing to it; add noise. The noise
adds some randomness to the gradi-
ent that breaks up the banding
when you map colors down to the
Web palette.

THE RIGHT WAY TO SAY HELLO
Most graphics work flows follow a
simple path: acquire, select, edit
and apply effects. Acquired images
come from cameras, scanners or

stock imagery. Once you have the
image, you can really start to work.
And, the place to start is a really
good selection.

THE RIGHT SELECTION
Oval and rectangular selections are
a cinch with The GIMP. Simply
choose the appropriate selection
tool, click and drag—instant selec-
tion. But, most selections are not

as simple. They require shapes
whose geometry would frighten
Euclid (check with your high-
school math teacher if you’ve for-
gotten that reference). What we
need is an easy way to draw the
selection, without having to trace
fine lines.

THE RIGHT WHITE (AND BLACK)
Photographers have long cursed

the sun for washing out their pho-
tos. But long ago, a simple solution
for most of these problems was
discovered—white balance. The
contrast in a washed out image
does not run the range from fully
black to fully white. Auto-Levels
helps you fix that easily.

Say hello to Auto-Levels.

TUX EXPLAINS
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Figure 11. Start with a single layer
image. If your image has multiple
layers, duplicate the image (Image→
Duplicate) and flatten it. Then open
Filters→Animation→Playback
(Animation Playback in 1.2). The ani-
mation playback window shows the
bottom layer of your image, which is
why you want to flatten it first, at the
same scale. Simply drag the image
off onto another window.

Figure 12. Both versions of The GIMP
offer thumbnail previews. The pre-
views are not generated without your
request, but click on the preview
frame, and the previews are generat-
ed for you. This image shows the File
Selection dialog from GIMP 1.2 (fore-
ground) and GIMP 2.0.

Figure 13. After you’ve created your
gradient, choose Filters→Noise→
Noisify. The preview shows noise
throughout the preview, but only your
selection in the canvas will actually
have noise applied. Deselect the
Independent toggle and adjust the
sliders down a bit—the amount you
use will take some experimentation.
Remember, Ctrl-Z is your undo friend.

Figure 14. Once the noise is applied,
you can map your image to Indexed.
Select the Web custom palette. If the
image doesn’t look right, undo the
mapping and the noise, and then
apply an adjusted amount of noise
and map again.
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THE RIGHT DIMENSION
Giving your designs a 3-D look is
nothing more than a bucket fill, blur,
emboss and sharpen. This four-step
process takes all of a minute to per-
form, though the real trick is in cre-
ating the initial shape. Sharp corners,
straight lines and long curves work
well. Avoid twisty shapes where lines
criss-cross each other frequently.

GIMP 2.0 EXTRAS
Although the tips so far have been
for both versions of The GIMP,
GIMP 2.0 has some added features
that must be mentioned. The Full
Screen Mode (press F11 to toggle
it on and off) is highly useful.
Dockable dialogs help clear the
clutter of windows you can have
open at one time—this is some-

thing even Photoshop doesn’t
appear to have (unless it’s in
recent versions unseen by this
author). All option menus can be
scrolled with a wheel mouse if you
have one. And, the Show/Hide
options for Guides, Rulers,
Scrollbars and other features help
make your workspace truly yours.�
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Figure 15. Use the Free Select tool
(what Photoshop calls the Lasso) to
draw a quick but not so accurate initial
selection. Then click on the QuickMask
box. This gives the area outside the
selection a reddish tint. Drawing with
any paint tool on the Canvas window
now modifies the area with red tint. In
this way, you paint out (with black) or
paint in (with white) areas to be
included in the selection. Click on the
QuickMask button again to toggle
back to the marching ants outline of
the selection.

Figure 16. Nearly every scanned pho-
tograph requires some sort of touch-
up. One of the first things to try is
Auto-Levels. Although this doesn’t fix
every scanned image, it helps the
majority of them. Open the Levels
dialog (Image→Colors→Levels in 1.2
and Layers→Colors→Levels in 2.0).
The histogram at the bottom of this
image shows that the distribution of
pixels from black to white is more
uniform than the original (shown in
the full-sized Levels dialog).

Figure 17. A simple example shows
this trick best. In a white canvas,
draw a rectangular selection. Fill this
with black. Then draw an oval selec-
tion inside this area and fill it white.
Choose Filters→>Blur→Gaussian
Blur (RLE) and blur by 3 pixels in
both directions. Finally, open the
Emboss filter (Filters→Distorts→
Emboss), and adjust the sliders to
get the effect you need.

Figure 18. Dockable dialogs are a big
boon to space-hungry users.

Michael J. Hammel is an author, a graphic
artist, Web designer, and software developer
currently working for RLXTechnologies in
Houston, Texas. He has spoken at the ALS,
LinuxWorld and SXSW conferences and chaired
multiple conferences on Linux in Colorado. He
is primary maintainer for the MiniMyth build
system, and he runs XEUS, his own develop-
ment site for XNotesPlus, Ximba Radio and
other open-source software. He can be
reached at mjhammel@graphics-muse.org, and
his blog is at http://www.ximba.org/wordpress.
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Adobe’s Portable Document Format (PDF) is a popular
way to exchange documents, and with good reason:
PDF files are snapshots of your documents that retain all
the formatting—fonts, layout, graphics and more—of
the originals. If you’re an office worker or small business
owner who needs to create and distribute electronic
documents, PDFs are a great way to go.

One my favorite features of OpenOffice.org is its
built-in PDF writer. All you have to do to create a PDF is
open a document and select Export to PDF from the File
menu. However, the PDFs that OpenOffice.org creates
are plain vanilla. They contain no bookmarks, no links
and they can grow quite large.

You can get more control over the PDF files you cre-
ate with OpenOffice.org by using an add-on called
extendedPDF (http://www.jdisoftware.co.uk/pages/
epdf-home.php). There are two versions of extendedPDF
for Linux, a free edition and the commercial Universal
edition, which contains more features. This review
focuses on the Universal edition.

As its name implies, extendedPDF enhances
OpenOffice.org’s PDF capabilities. Not only can you create
PDFs with links and bookmarks, you also can specify the
finer details, such as the colors for the links, the quality
of the PDFs being output and more. You even can add
security to your PDFs.

INSTALLING AND USING EXTENDEDPDF
Installation is easy. You simply run a command-line
script, which installs the add-on in OpenOffice.org. 
The installation script also adds an extendedPDF icon 
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Adding PDF Power to OpenOffice.org
extendedPDF is a product for people who need more than the OpenOffice.org feature that saves documents in PDF format.
SCOTT NESBITT

Figure 1. PDF Settings Tab

http://www.jdisoftware.co.uk/pages/
http://www.jdisoftware.co.uk/pages/epdf-home.php
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to the OpenOffice.org toolbar.
Once it’s installed, extendedPDF is

simple to use. You merely have to 
create and save a document, and then
click the extendedPDF toolbar icon. 
The add-on scans your document and
opens the extendedPDF configuration
dialog box.

The extendedPDF configuration dia-
log box consists of five tabs that give
you considerable control over your out-
put. Here is where you can specify col-
ors for the links, the quality of the PDFs
being output (for on-screen viewing,
printing, for use as e-books or for pre-
press work) and whether your PDFs are
compatible with newer and/or older 
versions of PDF readers. The Security
tab lets you add a password for opening
the file, and it can restrict others from
changing or copying the content in 
the PDF.

If you’ve used OpenOffice.org’s built-in
PDF writer, you’ll notice that extendedPDF
takes longer to produce a file. That’s
because the add-on looks at all the head-

ings and uses the information it gleans
from them to build a set of bookmarks.
Adding security and links also adds to the
generation time. Although it takes
extendedPDF a bit longer to create a PDF,
the quality of the resulting file is signifi-
cantly better than that of one created
natively by OpenOffice.org.

THE POSITIVES
The main advantage extendedPDF has is
the control it gives you over your PDF
files. It also comes with very good docu-
mentation that explains in detail how 
to install, configure and use the add-on.
Depending on the options you use, 
the PDFs created with extendedPDF are
only a few kilobytes larger than those
created with OpenOffice.org’s built-in
PDF writer.

THE NEGATIVES
My main gripe about extendedPDF is the
installer. It’s a command-line script. In
order to get it to install the add-on, you
might need to edit the installation script

to point to the directory where
OpenOffice.org is located. This is
explained in both the manual and the
installation script. But, unless you’re com-
fortable with editing scripts, you may
need to get someone to help you out.

On top of that, the extendedPDF
Universal edition costs around $38 US
at the time of this writing. If you’re
adamant about using only free soft-
ware, you might balk at paying that
much and stick with OpenOffice.org’s
built-in PDF exporter.

CONCLUSION
Overall, though, I’ve found extendedPDF
to be well worth its price. The quality of
the output is excellent, and the options
add much-needed flexibility to
OpenOffice.org’s PDF capability.

If you’re serious about your PDFs,
you should give extendedPDF a try. You
might find it to be an OpenOffice.org
add-on you can’t do without.�
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Although it takes extendedPDF a bit longer to create a
PDF, the quality of the resulting file is significantly better
than that of one created natively by OpenOffice.org.

Scott Nesbitt is a
journalist and tech-
nical writer living 
in Toronto, Canada,
who has con-
tributed articles,
essays and reviews
to more than 30
publications. You
may have even
heard of one or
two of them.
Although he works
with a lot of tech-
nology, Scott 
doesn’t own a PDA
(but he recently got
a cell phone), nor
does he have a car,
any pets or a single
pair of khakis.
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In the last issue of TUX, we took some time
to go through a powerful and fast word
processor called KWord, distributed as part
of the KOffice suite.

This issue, we look at AbiWord, a very
smooth and polished word processing appli-
cation that performs remarkably well on
Linux, but also on Mac OS X and even
Microsoft Windows.

Although AbiWord is not the only cross-
platform word processor (there’s also
OpenOffice.org, for example), it features
improved performance with much shorter
load times and a much higher degree of
responsiveness.

Recent releases of the application show
how much it has evolved since its early days.

The clean and polished user interface, the
much-needed support for Microsoft Office
and OpenOffice.org document formats, and
the brilliant integration of document history
and revision control make AbiWord a remark-
able desktop application, whether for per-
sonal or corporate use.

Usability-wise, AbiWord offers all the
features we have come to rely on in a word
processor over the years, such as the usual
shortcuts (Ctrl-B for bold, Ctrl-I for italic and
Ctrl-U for underline), the ability to insert
files (even from different formats) and HTML
export (although I could not find a PDF
export function).

AbiWord also extends the traditional
model by adding some key features that are
uncommon in similar applications, such as
the mail-merge system that allows you to
use a document template and a data source

(such as a database or CSV
files) to automate the process
of creating customized tem-
plate-based documents in 
large numbers.

Note that some of the ideas
for the next major release of
the project indicate that a lot
of additional features and
enhancements are currently
being worked on by the devel-
opment team, and the weekly
project news is a good testa-
ment of the development
activity around the project.�

— X a v i e r  S p r i e tAbiword in Action

AbiWord allows you to save your documents in any of the
industry-standard formats.

About AbiWord:

• License: GNU General Public License (GPL)
• Price: Free
• Web Site: http://www.abisource.com

AbiWord

http://www.abisource.com
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Instant messaging has become one of
the most popular activities on the
Web these past few years. Several
networks have emerged, offering a
standard set of features as well as
some network-specific additions, in
an attempt to attract a larger share of
this booming market.

The number of existing markets pro-
vides a healthy level of competition,
keeping companies such as Microsoft,
AOL or ICQ hard at work to provide
users with the best possible experience,
but it also adds a layer of complexity
for users as they need to sign up for
accounts with all these providers and
then use proprietary clients for each of
these networks.

The Gaim Project is a multiprotocol
IM client that allows users to join and
use a plethora of networks, such as
MSN, ICQ, AIM, Jabber, Yahoo! and
many more, through one coherent
interface.

Gaim can be used on your GNOME
desktop, but also on KDE and even
Microsoft Windows, so you can use
the client on virtually any environ-
ment. Gaim also integrates itself into
your taskbar and provides a configu-
ration dialog that allows you to cus-
tomize the behavior of the application
completely.

Additionally, Gaim supports an

advanced plugin system that allows
developers to provide additional func-
tionality as they see fit. Many plugins
are available, such as Guifications, that
allows Gaim to display notifications on
the corner of the screen to inform you
that someone is typing a message or
that someone just logged on (you even
can configure which events should
trigger a notification).

The Gaim developers also have
become experts in keeping up with
changes in the different networks,
thus providing a very reliable product
to their users.

On a usability point of view, Gaim
provides a smooth interface that,
although not very customizable, offers
features such as the ability to drag and
drop contacts into categories, groups or
messages; modify your account informa-
tion; join chat-rooms; or create buddy
pounces, a system that performs custom
operations when a certain member of
your friends list changes status (it
sends a message when a particular
user logs on).�

— X a v i e r  S p r i e t
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About Gaim:

• License: GNU General Public License 
(GPL)

• Price: Free
• Web Site: http://gaim.sf.net

Gaim

You can select from any protocol when
creating your account.

Gaim integrates in the GNOME notification area.

http://gaim.sf.net
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With digital distribution of music through the
Internet becoming more convenient and popu-
lar by the day, simple playlists just don’t quite
cut it anymore. This is precisely the reason why
Apple’s brilliant iTunes software has attracted so
many users by offering a clever way to manage
large playlists.

Rhythmbox is a music library manager and
player for the GNOME desktop environment
(although it does work under KDE as well) that
provides similar functionality by organizing
your playlist by authors or albums and offering
fast search functionality.

The application is simple to use and visually
appealing, and it allows users to play and organ-
ize large playlists any way they want, including
on-line radio stations.

This is no small undertaking considering the
massive size of some playlists featuring thousands
of songs, all in different formats and with differ-
ent naming conventions.

Rhythmbox also offers users the ability to rate
specific music files, and this rating can be used to
sort songs in order to obtain a listing of your
favourite music files across an entire filesystem.

The user interface is intuitive, and none of the
important features seem to be missing (taskbar
integration, mini-mode, multimedia key control
and so on). All these factors contribute to making
Rhythmbox a serious player in the modern digital
music world.

Another great advantage Rhythmbox has over
similar products is its ability to play a wide array of

audio formats, through its use of the GStreamer
framework, a state-of-the-art media-handling
development platform.

Although the application currently lacks the
ability to edit ID3 Tags, the Rhythmbox FAQ on
the project’s Web site indicates that this fea-
ture will be available in future releases, and it
recommends the use of the EasyTag product to
perform this operation (http://easytag.sf.net).

It also is worth mentioning that Rhythmbox sup-
ports many playlist formats, which makes importing
playlists from other applications quite trivial.�

— X a v i e r  S p r i e t
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Rhythmbox

Managing a Large Playlist with Rhythmbox

Rhythmbox in Small Display Mode

Taskbar Integration

ID3 Details Dialog

About Rhythmbox:

• License: GNU General Public License (GPL)

• Price: Free

• Web Site: http://www.rhythmbox.org

http://easytag.sf.net
http://www.rhythmbox.org
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In our review of the Rhythmbox music
library management system, we men-
tioned that the underlying platform 
for media playback was GStreamer 
and that this was a key feature of the
application.

Totem Movie Player is a complete
media player that also relies on the
GStreamer framework as well as the
Xine library to play audio and video in a
wide array of formats and encodings.

On the major features front, Totem
offers a simple interface for video or
audio playback, supports network 
audio and video streaming media as
well as a plethora of file formats, 
audio vizualisation, CD and DVD 
playback (with DVD navigation), 
TV-Out support, LIRC for infra-red
remote-controls and full integration 
to your GNOME desktop.

It also is worth noting that the latest
release of Totem offers support for propri-
etary plugins, which means that plugins
should start to appear shortly.

Although Totem uses Xine and
Gstreamer as back ends, it offers a
much more visually appealing and 
modern front end than the official Xine
user interface, while benefiting from

the excellent reliability and quality of
both platforms.

The end-user documentation of the
application is pretty straightforward and
does a good job of highlighting most
major features without going into too
much detail.

For the last few major releases of the
GNOME desktop environment, Totem
has been the default video player, so it
is very likely already installed on your
Linux distribution. Just in case though,
the author has been thoughtful enough
to provide binary packages for most
major Linux distributions out there, 
and chances are that your distribution
probably provides its own binary 
package for Totem.�

— X a v i e r  S p r i e t
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Totem Movie Player

Totem’s Audio Visualization

Totem Video Playback

About Totem:

• License: GNU General Public License 
(GPL)

• Price: Free

• Web Site:
http://www.hadess.net/totem.php3

http://www.hadess.net/totem.php3
http://www.tuxmagazine.com
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What do the following relatively recent movies have in com-
mon? The Incredibles, Shrek, Shrek 2, Lord of the Rings, Harry
Potter and the Sorcerer’s Stone, Titanic, Ice Age, Spawn, Spirit,
Stallion of the Cimarron, Sphere, Peter Pan, Bunny, Barbie of
Swan Lake, Joe Fly & Sanchez, Los Gringos and The Night of the
Headless Horsemen? These are just some of the most notable
movies that include computer animation rendered using Linux.
In some cases, the movies were rendered entirely on Linux.

There are several reasons why Linux is now essentially the de
facto standard platform for rendering computer graphics. First,
Dreamworks, the company that turns out one blockbuster hit
after another, is using Linux almost exclusively for its back-end
render farm. The last I heard, Dreamworks has Linux running on
2,000 CPUs, but that has likely increased. Second, the Linux ver-
sion of Alias’ Maya, one of the most advanced 3-D graphics
tools, has matured on Linux during the past few years. Third,
even more software is being released for Linux. About a year
ago, Amazon Paint System with OpenGL 3D Paint was released
for Linux. This popular software has been used in Monsters Inc,
The Matrix, The Grinch and others.

The fourth point is obvious. Linux is free. But that wasn’t
always enough. One of the biggest motives for the large-scale
commitments to Linux is the fact that hardware—especially

graphics hardware—is far less expensive than it used to be,
thanks in great part to NVIDIA. When companies like
Dreamworks had to spend thousands of dollars for each
machine or graphics card, the fact that Linux was free didn’t
do much to offset the cost of building a large-scale rendering
farm, especially if Dreamworks had to pay for programmers
to adapt existing software to run on Linux. Today, however,
both Linux and hardware are so cheap that a thousand-node
Linux rendering cluster is a fraction of the cost of any 
competing solution.

BRINGING IT HOME
By now, you must be wondering why this should be important
to you, the desktop Linux user. Call it a long shot, but I’m
guessing not many of you have $500,000 to spend on a profes-
sional rendering cluster, no matter how impressed you may be
that these clusters deliver better performance for 20% or less of
the cost of previous systems.

Aside from all of the media exposure and increased credi-
bility this trend gives Linux, there are other benefits that spill
over to desktop users. Movie studios learned quickly that
decreasing hardware prices and free Linux combine to lower
the overall cost of producing better animation. This puts

The Light and Dark Side of Linux Multimedia
Linux is taking over the world when it comes to rendering 3-D graphics for today’s movies. That translates to good
news for the Linux desktop user, but it would be better news if only media companies would get a clue about theft.

NICHOLAS PETRELEY

THE LAST WORD
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pressure on NVIDIA and its competi-
tors to deliver better quality products
at lower prices to the studios.
Yesterday’s professional graphics
cards quickly become tomorrow’s
consumer graphics cards. More
important, these cards were
designed to run with Linux, so the
hardware companies can no longer
view Linux as an afterthought when
it comes to drivers.

THE MONKEY WRENCH
A couple years back, Sony declared
that Linux would be the standard
platform for all future multimedia
devices. As an aside, I would love to
have seen the expression on the
faces of the folks at TiVo when they
read that press release. TiVo is the
company that revolutionized the way
we watch television when it pio-
neered digital video recorders that
let you pause, play back and record
programs more easily than anyone
thought possible. And TiVo did it all
with Linux long before Sony jumped
in the game.

Regardless, Sony and its competi-
tors (and to a lesser extent, TiVo) are
more or less in the position to
endorse digital rights management.

So anything they bring to the table
as far as Linux is concerned doesn’t
improve the current absurd patent
and legal situation faced by Linux
desktop users. We still need groups
like the Penguin Liberation Front
(PLF) to provide us with the arguably
illegal decoding tools to do unarguably
ethical things like watch a DVD on a
Linux desktop.

What irks my goat most about
this situation (if you’ll pardon the
mixed metaphor) is that the problem
of digital multimedia theft has little
or nothing to do with things like
decryption software provided by
underground organizations like the
PLF. DVD decryption is a minor step
in the process of shrinking a DVD to
a size that is easier to download
from a peer-to-peer sharing network
like Gnutella, which is where the
theft takes place.

I am against theft of copyrighted
materials that cannot be justified by
fair use. But the solutions media
providers are exploring are doing
more damage to their businesses
than good. The DVD issue is a bit
complex and deserves its own col-
umn, so I’ll save that topic for the
future. But I think I can make at least

one point by citing an example that
involves MP3 files and music.

I recently purchased a CD player
for my daughter that plays regular
CDs or custom-made CDs with MP3
files organized in directories for easy
navigation. I’ve been going through a
nostalgia phase lately where I’ve
wanted to listen to some old jazz,
Beatles and Beach Boys songs. So I
figured I’d pick up some cheap oldie
CDs and make an MP3 CD of my
favorite oldies. To my shock, I found
that the stores still sell these ancient
relics as individual albums in CD form
for $15 each, more or less. I not only
refused to buy any of these CDs, I
spitefully downloaded a few of the
MP3 files I wanted based on fair use,
because I owned the vinyl records.

Now, if media companies crammed
MP3 files of the complete works of
any baby-boomer artist onto a few
CDs and sold the sets for $20 each, I’d
buy them in a downbeat. I bet many
of you would too. That’s matching
price with value, which inhibits theft.

The bottom line is that theft 
didn’t start with DVDs, it didn’t 
start with Linux, and it only will 
get worse with greed-driven digital
rights management.�
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TUX is the first and only magazine for
the new Linux user. In each digital edi-
tion of TUX, we explore every facet of
the modern Linux desktop, providing a
new breed of Linux user with the tools
and information to make their Linux
desktop experience complete.

A new breed of Linux user has emerged,
the Linux consumer. TUX delivers to this
powerful and rapidly growing economic
force by offerring many advertising
opportunities for both its digital edition
and its web site.

ADVERTISING

Contact the TUX team
today to have a media kit
sent to you. E-mail
ads@tuxmagazine.com or
call 206-782-7733 ext.4

www.tuxmagazine.com

UPCOMING ISSUES INCLUDE:

June 2005
The LIVING WITH WINDOWS Issue
Is yours a house (or office)
divided? With Linux PCs here
and Windows PCs there? In the
June 2005 issue, TUX shows
you all you need to know to
share files and folders between
these different systems. We'll
also look at tools that make
running Windows on Linux (and
vice versa) easy.

July 2005
The MONEY Issue
If money makes the world go
'round, this is a well rounded
issue of TUX as we explore finan-
cial applications in the Linux
world. We'll cover home finance
programs that provide simple
cheque book functions as well as
those that do it all. Join us as we
explore expense trackers, stock
tickers, and business-ready
accounting software. Ka-Ching!

August 2005
The EDUCATION Issue
TUX goes back to school in the
August 2005 issue. Linux systems
are a great solution for cash
strapped schools, but they offer
much more than inexpensive, 
stable, and secure systems. Kids 
will find software to challenge their
minds and have fun doing it. From
Linux at school, to educational 
programs, to educational games,
it's Linux for kids of all ages.

September 2005
The SWITCH Issue
Finally, it's time to help those in
need. Yes, we're talking about
people running something
other than Linux—those poor
unfortunate souls who deal
with adware, spyware, and 
system crashes every day of
their lives. TUX will look at great
Linux business tools, live Linux
CDs (to introduce your friends
and family), and transitional
applications (Linux programs
that are available for Windows)

so that even if they continue to
run something else, they can at
least get some of the benefits
of Linux.

October 2005
The LINUX AUTOMATION Issue
Whatever happened to computers
making our lives easier and giving
us more free time? Maybe it's
because they weren't running
Linux. This October 2005, TUX
will show you how to put your
Linux system to work while you
sleep! Let Linux take care of
business and watch over things
while you tend to other, more
important things. In this issue,
TUX will look at home security,
webcams and video surveillance,
maybe even a robot or two.

November 2005
The PERSONAL COMMUNICATIONS
Issue
As the end of 2005 approaches,
talk is hot again and Linux makes
it easy. The year 2000 has come
and gone, but picture phones are

finally here, instant messaging is
everywhere, free long distance
is a reality, and everybody is
reaching out and touching
somebody somewhere. Get into
the instant messaging, Voice
Over IP, text messaging, and just
plain talking action in the
November 2005 issue of TUX.

December 2005
The LINUX ON THE ROAD Issue
It's December 2005 and people
are on the move, whether to visit
family for the holidays or jetting
off to somewhere warmer. Either
way, you'll need to take your
Linux computer along. Don't
have one yet? Not sure of the
tools you'll need? Let TUX show
you the best tools for Linux 
notebooks, network applications,
WiFi, Bluetooth, and everything
else you need to stay connected
when you are away from home.
We'll take a close look at personal
digital assistants, cell phones,
and much more when TUX hits
the road.

TUX magazine
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